Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Windows 7 64bit and the machine is connected via a KVM, so I have to use PS2 mouse connector (the machine is about 20' behind me in the office somewhere) as the KVM doesn't switch USB.

Using a number of different mice (different makes, Logitech, Microsoft, no-name cheapo brand) when using the scroll wheel it causes Internet Explorer to act as if the "back" button has been pressed, and causes Visual Studio to act as if the "pop-context" has been pressed. This is, being mild, annoying.

Further investigation reveals that when I scroll it looks like the BUTTON4 & BUTTON5 buttons are being pressed (I found this using MouseInfo in Microsoft's Intellipoint suite).

Now, plainly BUTTON4 or BUTTON5 are mapped to "back" or "forwards". Given that my mouse doesn't have button4 or 5 - what can I do to disable this "feature" - or even remap them to something else?

I tried installing Intellipoint 8.x from MS, but that won't work as it doesn't support PS2 mice (gah!). And a previous version of Intellipoint 64bit won't run as it is blocked on the compatibility list.

I tried writing a .NET low level mouse hook - but not sure what the codes are for button 4 & 5 (it looked like it was mouseinfo == 0x780000) - but when I filtered that out, it still happened - so either my filtering failed (I just returned a pointer to null rather than next mouse hook) or I was looking at the wrong number.

Can I remap what BUTTON4 & 5 to do nothing at all?

Failing that, I am happy to write some software that will pickup on that event and bin it - but I need to do so before IE / Visual Studio IDE get hold of the event - but could someone point me in the right direction?

share|improve this question

migrated from Mar 5 '11 at 18:01

This question came from our site for professional and enthusiast programmers.

When Windows boots it negotiates with the mouse to determine what format data it's going to be sending. If several computers are sharing the same mouse via a KVM they can become confused about what to expect from the mouse. If this is the problem (you can test it by plugging the mouse directly into the computer, rebooting and seeing if the problem goes away), the simplest solution is to find a dumb mouse (i.e. three buttons, no scroll wheel) that doesn't negotiate. – arx Mar 5 '11 at 15:43
Sorry, I meant two buttons. – arx Mar 5 '11 at 15:48
up vote 2 down vote accepted

I found a solution to this - I installed AutoHotkey and put a script with these lines in the startup folder:

share|improve this answer
How do I now mark this answered? – Manicguitarist Mar 6 '11 at 19:52

Or you can try another solution, try changing your mouse type (for me worked with Wireless Intelimouse explorer 2.0) and deactivate button 4 and 5. Apply. let it with that spec mouse and you don't have problems.

Another trick: In Wheel Button, define action to: Click with middle button...

No problems :)

share|improve this answer

I also have same issue, pretty much boiled it down to the KVM switch, I think it has to do with faulty KVM, we use several and only have this issue on a couple of them. I found that buy unplugging the mouse then plugging it back into the kvm the problem will go away for a while but returns somewhere down the line. Short fix but does help with the frustration. :)

share|improve this answer

I'm using old PS2 KVM and too cheap to upgrade to USB since it functions. So I'm using USB to PS2 adapter for mouse. This problem of Navigate Back when using Wheel Up with Win XP. I've seen on some other PCs too. I solved that with 32-bit Intellimouse driver from Microsoft. Now with newer Win 7 PC on my KVM, same problem. I am using a Kensington mouse, previously using a Logitech. I just installed Intellimouse x64 driver and tried various options for a few mintues. I settled on Intellimouse Explorer 4.0 -- wired model -- and disabled the Back button. Problem wasn't caused by clicking the Back button but apry the Wheel Up (to top) action activated the Back button action. That works! The tips here helped me proceed with Trial and Error.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.