Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I type stuff in the Windows 7 search box in Explorer, it keeps updating and searching as I type which is annoying, frustrating, and pointless. Is there a way to get Windows to knock it off and let me finish constructing my query and press Enter before it starts searching?

share|improve this question
    
Look away while typing? – mtone Apr 18 '11 at 21:17
    
@mtone, what‽ How does that stop the stupid thing from slowing my system to a crawl as it tries to search my drives before I’m even finished typing the query? Duh. – Synetech Apr 22 '11 at 21:27
    
@Synetech inc. Sorry, on a fast system with the most searches done in indexed locations, it is hardly noticable and typing is not delayed. Which I believe is the intent of this feature - that is quickly fetching results in the background. I can understand in some situations (older PCs or laptops, limited RAM, non-indexed folders) it may be annoying. – mtone Apr 28 '11 at 22:29
1  
@Synetech inc. - Just wanted to document this. You're the only person I've ever seen use an interrobang as one character, as it should be. I don't even remember the alt code to make it. – Joseph May 24 '11 at 20:17
1  
@josmh, I don’t thing there is an ALT code because it is one of the really high ones (8253), which as far as my testing has determined, cannot be entered with Alt. Whenever I need one, I just Google ‘interrobang’ and copy the character. ;-) (I tried adding it to my hotkey/macro program that I use to insert other accented characters, true-quotes, fractions¼, etc. but it doesn’t support true Unicode so I couldn’t.) – Synetech May 24 '11 at 20:31

Try turning off "find partial matches"

Choose Start > Documents. In the upper-left area, click the down-arrow next to Organize. Choose Folder and Search Options. Select the Search tab.

enter image description here

share|improve this answer
1  
Nope; it still searches as I type (which makes it really hard to type). – Synetech Mar 6 '11 at 3:56

I'm pretty sure this is a feature and cannot be turned off. Turning it off would essentially relegate the functionality back to XP.

share|improve this answer
1  
“Turning it off would essentially relegate the functionality back to XP.” …and make it usable again. – Synetech Apr 11 '11 at 19:27

Annoying as hell, I agree, but easy to get around. Before you type anything else, type a row of X's. It'll start to throw up X-box, etc, but when you get to about five X's it'll shut its mouth in bafflement and you can type in your search in peace, like so: 'xxxxxxxwhy does google copy every damn thing I type in without letting me finish?'. You can even make typos without a single red wavy line appearing. Peace at last. Just highlight and delete the X's before hitting 'enter'. Soooo much better for your blood pressure, I find :)

share|improve this answer

I do not have a solution for the Explorer functionality, but my workaround is to pop open Notepad and type whatever I want to search for, then copy it and paste that into Explorer. (I do this for Google searches as well now that Google behaves like Windows 7 thanks to its Instant Search function.)

My Notepad solution involves a keyboard hotkey, so you can put a shortcut to Notepad on your desktop or somethwere, right-click it, select Properties, and type a shortcut key in the appropriate field. (I use T.)

My sentiments are that keyboard > mouse, so my process ends up being:

  1. Open Notepad                               (e.g., Ctrl+Alt+T)
  2. Type my search terms
  3. Select all                                        (Ctrl+A)
  4. Copy                                              (Ctrl+C or Ctrl+Ins)
  5. Switch to the Explorer Window     (e.g., Alt+Tab)
  6. Activate the search field                (Ctrl+F or F3)
  7. Paste                                             (Ctrl+V or Shift+Ins)
  8. Search                                           (Enter or just wait a second for it to automatically search)

It seems lengthy but is actually quite quick.

share|improve this answer
1  
Interesting work-around. I use a similar approach to get around programs that retain formatting of copied text. Whenever I copy something (e.g., from a web-page) and want to paste just the text without HTML tags, I paste it into the Run dialog and copy it back to the clipboard. I use the Run dialog because it is not a separate program, so it is extremely fast to run and already has a hotkey to initiate it (Win+R). As for Google, you can disable Instant Search (which like many I think is horrible), by using the Search Preferences option. – Synetech May 18 '12 at 19:28

In Windows Explorer, go to Organize → "Folder and search options". Go to the View tab, scroll down, and under "When typing into list view" select "Select the typed item in the view".

share|improve this answer
    
this doesn't answer the question – bfhd Jun 26 '15 at 4:30
    
It's off-topic, but thanks anyway, because you answered my burning question: How to prevent Explorer from jumping into the search field instead of selecting the typed item as it used to do. :-) – msp Aug 4 '15 at 7:46

As a work around, search in uppercase. This seems to work for me.

share|improve this answer
    
Really? That’s odd because I just tried it and it doesn’t work. Maybe you typed too fast; Windows delays a moment before it starts, but if you type too slow, it will start searching even if you don’t press Enter (which is the behavior I am trying to enforce). – Synetech Jul 12 '13 at 1:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .