Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ubuntu 10.10, XTerm(261), Keyboard layout = Canadian

Somehow, the backquote (backtick = `) character can't be input does not get entered in XTerm. I type it and nothing happens. The cursor does not move forward.

I know it works because I can input it in Terminal (gnome-terminal). The only strange thing is that I have to type the key twice for it to appear.

Just to test it, I tried typing it in other applications, and the same thing happens. Have to type it twice in FF, gedit, etc. One more strange thing, I could not input it into this textbox in which I am typing this message. But I can input it in the URL bar, search bar, etc.

Someone please help me solve this mystery. I like to use XTerm and I need the backquotes.

share|improve this question
    
I think it has something to do with the keybindings. Found a post for Terminal on Mac OS X. It was a specific plugin in that case. –  Cocoro Cara Mar 6 '11 at 8:07
    
termcap? terminfo? maybe that has something to do with it ... something is intercepting that backtick ... all other special characters can be input without problem. –  Cocoro Cara Mar 6 '11 at 8:49

1 Answer 1

One possibility to disable dead keys might be to change your keyboard layout in system preferences to something that doesn't use them (like US).

You will notice, by the way, that in addition to pressing backtick twice to get one backtick character, you can press it once then press "e" to get a "è" (LATIN SMALL LETTER E WITH GRAVE).

share|improve this answer
    
What I don't understand is why I can't enter it into XTerm and some select places (like this textbox). Note that I can enter the e with grave è in this textbox. But not the backtick itself. I can type the accented é into XTerm as it is a key on the keyboard. I don't want to change the keyboard layout. There has to be a reason and some solution. –  Cocoro Cara Mar 6 '11 at 16:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.