Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using VirtualBox to boot into my XP image. I am using cable broadband (via LAN). I can browse the internet in my host but not in my virtual machine.

share|improve this question
    
What mode of networking are you using on VirtualBox? –  Majenko Mar 6 '11 at 10:51
    
What type of virtual connector is your virtual machine using (ie, bridged, NAT)? Does the virtual machine receive a valid IP address –  user70389 Mar 6 '11 at 10:53
    
hi Matt, i have test all (NAT, Bridged adapter, Internal Network, Host -only adapter) nothing works –  Vijay Bobba Mar 6 '11 at 10:54
    
I have used both but not able to access internet, second, the valid IP address: IP address is given by the service provider (a Static one) and we have to manually configure it –  Vijay Bobba Mar 6 '11 at 11:11
add comment

1 Answer 1

up vote 1 down vote accepted

Things to try:

  1. Set the networking type to Bridged Mode paying attention to which network card it is bridged with.

  2. Make sure the latest version of the VirtualBox guest additions are installed.

  3. Check the network settings in the guest OS to confirm that:

    • The network card is detected and configured
    • A valid IP address has been provided by your router
  4. You can communicate between the host computer and the guest operating system (ping)

share|improve this answer
    
i have a doubt, the IP adress is actually a static one which was given by the network provider, we (users) will configure this IP manually (LAN), now i usually do not have an another IP bcs only one IP can be given to a connection, so i have used the same in the virtual machine, is this approach is wrong? guess we can't use same IP on host and on VM? If, so is there any way to solve my problem (like sharing the internet b/w host and VM) –  Vijay Bobba Mar 6 '11 at 11:17
    
Ah, so you have cable modem linked direct to PC? In that case you will need to use NAT mode and the VirtualBox built-in DHCP server. Set your guest OS to obtain an IP automatically. –  Majenko Mar 6 '11 at 11:31
    
you are great!!!!!!!!!!!! it works. Thanks a lot –  Vijay Bobba Mar 6 '11 at 14:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.