Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to connect to internet I keep getting the error Unidentified network. I've tried numerous attempts at restoring access without success.

IP release, flushing DNS cache, reinstalling NIC, reactivating NIC, resetting router and so on...

I've read several times that it's my default gateway that's wrong. Currently I've had automatic IP/DNS configuration set without any problems, and then it stopped working for some reason.

Anyone know how I specify the IP? My subnet mask is 255.255.255.0, default gateway is 192.168.0.1 but I have no idea how to determine what IP I should set.

I use a D-Link DIR-655 and other computers on the network have IPs like 192.168.0.194, next is 192.168.0.197.

(I'm completely lost and am trying to cool down after two weekends of debugging filled with despair.)

share|improve this question

3 Answers 3

up vote 2 down vote accepted

You should have turned off IPv6 for all adapters as first step.

Other repair commands that you can try are :

netsh int ip reset c:\resetlog.txt   (reset TCP/IP stack)
netsh winsock reset c:\winsock.txt   (reset winsock)

Another possible issue is that the routing table contains a phantom default route to a non-existent network interface card. The solution is to use the Command Prompt as Administrator and remove all default routes:

route delete 0.0.0.0

then renew the DHCP lease by running ipconfig /renew to recreate the correct 0.0.0.0 route.
Check your routes by using the command route print.

Last possibility is to regard in regedit the key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces{GUID}
and do :

  1. If you have an entry "DefaultGatewayMetric" and the information is blank, delete that key
  2. If you have an entry "DefaultGateway" and the information is blank, delete this key as well
  3. Change the "DhcpConnForceBroadcastFlag" entry from 0 to 1

I suggest creating a system restore-point before doing these manipulations.

share|improve this answer
    
Nothing worked. I believe it to be a hardware problem. Thank you for your help, I bet it would've worked otherwise! –  Zolomon Mar 6 '11 at 17:55

Your default gateway in a home environment will typically be the same IP as your router. Double check the config on your D-Link router to ensure that DHCP is enabled.

share|improve this answer
    
The IP of my router is the one I've set as default gateway: 192.168.0.1 and DHCP is enabled. –  Zolomon Mar 6 '11 at 13:36
    
Hmm, not the gateway IP then, and you said that it's set to automatically retrieve and IP, so that's not it. Not sure what it could be then. –  BBlake Mar 6 '11 at 13:46

One of two possible causes comes to mind (the second of which includes two possible solutions):

  1. Your ISP is blocking various ports (e.g., they have an aggressive firewall policy) and Windows 7 is unable to contact Microsoft.Com to determine if you're really online.

  2. Your computer is trying to Register DNS but this is failing because the DNS server isn't allowing such changes (not uncommon). There are two ways to go about trying to resolve this:

       2a. If your router allows you to configure which DNS servers your DHCP clients get, then set them to the router's internal IP address (same as the internal gateway) so that it can manage this for you (this works with LinkSys routers, and hopefully yours too) as well as handling all DNS queries (which it will just pass along to the DNS servers assigned to it on the public side).

       2b. Disable the DNS Registration feature from within your TCP/IP v4 settings: "Advanced" button -> "DNS" tab -> "Register this connection's addresses in DNS" checkbox (second from the bottom)

Option 2a is definitely the better one. Hopefully your router supports that mode of operation (it should).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.