Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a Mac Mini on big flat-screen TV for playing media. The small font size is really annoying when sitting far away. Is there a way to increase the system font size in OS X?

share|improve this question
1  
I know Frontrow exists for this use case but I often need to navigate to Hulu or other sites. –  Greg Dingle Mar 6 '11 at 18:16
    
You might also try something like Plex, Boxee or XBMC, the latter two seem to have a Hulu plugin‌​. –  slhck Mar 6 '11 at 21:22
    
I'm interested if there is a way to do this per monitor also - apple.stackexchange.com/questions/74460/… –  studgeek Dec 10 '12 at 17:35

9 Answers 9

up vote 10 down vote accepted

There's no built in systemwide means of adjusting the font scaling, short of running at a lower than native Resolution. In general, OS X is a fairly poor choice for everyday use at a distance of 10 feet from the screen. That said, you have a few options:

You can increase font sizes on an app by app basis. The main one you'll be concerned with, it seems, is Safari, where you can adjust the default display fonts for web pages under Preferences->Appearance, and on any given page, you can adjust the displayed fonts on any given page you are viewing with +.

You can also make use of the built in 'Zoom' feature in OS X. To enable this, under System Preferences, go to Universal Access and turn on 'Zoom'. This will enable you to zoom in on a portion of your screen at greatly increased magnification with a keyboard shortcut. Some people love this, but I find it slightly disorienting.

You might also want to investigate whether one of the systemwide 'theming' apps will work for you. The only one I know to work currently with 10.6 is ThemePark. You can probably find more info to assist you in taking this approach over at the MacThemes Forums, but be advised that this sort of 'UI skinning' tends to be frowned on by Apple and break frequently. It's something of a high maintenance option.

Finally, if you're really just concerned with home-theatre type usage here, you might want to look into any of the many FrontRow replacement apps out there that offer better support for Hulu, Vimeo, Pandora et al. Some of the major names in this field are Plex, Boxee and XBMC.

share|improve this answer

Apple doesn't provide the capability, but third party apps might. You could try TinkerTool which has a Fonts tab that lets you modify system fonts. I haven't personally used it for fonts (although I do use it to change other things like Finder prefs) so I can't say whether it works or not.

share|improve this answer

There is a way by using command line parameters and it works throughout the system.

(for other readers: the solution works for MacOS X 10.6 "Snow Leopard", but not in 10.7 "Lion" or 10.8 "Mountain Lion")

Taken from here

If you want to increase the size of the menu bar font, you may want to try this. It should work on Leopard.

You will need to launch Terminal (its located in Applications -> Utilities).

Enter the following command.

defaults write NSGlobalDomain AppleDisplayScaleFactor 1.5

Then try launching some applications. You should see the menu bar size change as well as the application.

The last number "1.5" in the command means 150%. If you want to reset back to normal, use:

defaults write NSGlobalDomain AppleDisplayScaleFactor 1.0

Depending on your screen size and preference, you may want to play around with the number.

An unfortunate sideeffect is that everything in the webbrowser gets "shifted to the right" due to the increased size. however the size is otherwise great on our 42" tv, can actually read the top line (apple, file, edit etc).

i.e. to be able to see the "post your answer" button on the bottom of the screeen here I had to use cmd+ "-" to shrink the website.

share|improve this answer
1  
Fair enough, the question was asked about Mac OS 10.6 "Snow Leopard", but let's note that this setting no longer exists in Mac OS 10.7 "Lion" and Mac OS 10.8 "Mountain Lion". –  minopret Nov 23 '12 at 19:42

In 10.7 and later you can enable HiDPI modes by running sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool true and restarting.

The maximum effective resolution is half of the native resolution though, e.g. 960 x 540 for the internal display of my iMac:

Also this doesn't work with some (external?) displays anymore as of 10.9.

share|improve this answer

I could have sworn there used to be a preference to do this before, but I can't find it - perhaps a more able SuperUser-ee will know where it went. There are a couple of things you can do, though:

  • Try turning off LCD font smoothing, either entirely or for a higher threshold in the Appearance section of System Preferences.
  • Switch to a lower resolution in the Displays section of System Preferences. This will make everything bigger, at the expense of lower graphics fidelity.
  • Turn on screen zoom in the Seeing tab of the Universal Access section of System Preferences. Again, this will make everything bigger, but can be turned on and off as necessary.
  • Some applications have specific accessibility options: for instance, the advanced tab of Safari's preferences allows you to set a minimum font size that will be used, regardless of what a website requests.
share|improve this answer
    
-1 All of those don't change the font size system-wide. The correct answer is that Mac does not provide that functionality. –  Aleksandr Levchuk Nov 14 '11 at 5:32
1  
@Aleksandr Levchuk I didn't claim that any of them did. Since, as you point out, there is no way to provide exactly what was originally asked for, I attempted to provide alternative methods of solving the root problem. Thanks for bothering to explain your downvote, though. –  Scott Nov 14 '11 at 9:50

I am also running a Mac Mini on a large screen HD TV. Here are some steps I've found useful for this issue:

FIRST STEP: Set your resolution to 720p. You really shouldn't need full 1080p for anything other than watching BluRays, and that's better done on a dedicated player. Most internet streamed "HD" content is actually 720p, not 1080. If you are doing some sort of high end video editing or something, this may not be the best option for you, but for most, 720p is great.

NEXT STEPS: Changing the icon and font size in the folder view options, then setting as default will solve part of the issue. Open any folder in Finder, right click (ctrl-click) on the background of the folder and select "Show View Options." Icon size is near the top, and text size is around the middle. Set to your comfort level and click "Set as Default" at the bottom. Any finder window for which you have not already set these preferences will now open with these settings.

Next, change the font sizes in your browsers (that will solve nearly all of the rest of your issue right there). Chrome also has a VERY useful default zoom setting for web content, but it's hidden in the advanced settings. I find 125% to be perfect.

Obviously, you should also seek out similar settings for any other software you use on a regular basis.

LAST RESORT?: If that still isn't solving the issue to your satisfaction, there is a free application called TinkerTool that has a Font section. It will allow you to set the system fonts for just about anything. I don't know yet how well that works in Mavericks, so I can't guarantee it will do anything.

With my resolution at 720p, my folder-view defaults and browsers set, I haven't had much issue. I sit about about 12 feet away from a 52" screen.

share|improve this answer

Are you talking about Finder windows? If so, here's how:

  1. Open a new Finder window.
  2. Choose View > Show View Options from the menu bar (or press ⌘J).
  3. In the "Text size" pulldown, choose whatever font size works for you.
  4. Click the "Use as defaults" button at the bottom.

Which should just work…

share|improve this answer
2  
-1 not a system-wide change –  Aleksandr Levchuk Nov 13 '11 at 23:49
    
@Alek - did you downvote all the answers, given that they say the same thing? –  Dori Nov 13 '11 at 23:52
    
there are differences. Some of them are actually correct in that they give the right answer: Mac does not provide that functionality. Sorry if my -1 vote was unfair. I will try to make up for it. –  Aleksandr Levchuk Nov 14 '11 at 5:36

The problem is that the TV is set to too high of a resolution! 1080 can deliver features are smaller than the eye can see from across the room. Cool if you are watching a movie and can barely tell the wrinkles. If it's words you are trying to see, smaller resolution may work better. Poisoned by too much of a good thing.

-System Preferences -> Displays ->Resolution

--720p is makes the top left corner apple 1/2" in height in my 46" Sony. I can read it clearly from across the room.

It's practical, no scripts or add-on software. Try that. I can work with the computer better now.

share|improve this answer
    
Lowering resolution is one way to make fonts bigger. But it also reduces readability and otherwise degrades the display. And that's why the question is about increasing font size, not reducing resolution. –  Isaac Rabinovitch Nov 23 '12 at 3:52

Onyx Utilities

You can make many change there to the system and Apple applications like Mail, Safari, iTunes, etc

Be careful and remember what changes you made

share|improve this answer
2  
Can you please elaborate a bit, and perhaps add a link to the resource you referenced. –  dav May 31 '13 at 19:09
1  
@dav A month ago I added a link to Onyx Utilities to Jonny's original answer. The list of per-app settings can be also useful. (it's for Lion, but most answers apply to other versions as well) –  yurkennis Dec 26 '13 at 20:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.