Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a working copy, checked out from SVN repository.

When i'm trying to commit, i get following error:

svn: File not found: revision 57, path '/trunk/path/to/my/file/logo-mini.jpg'

I've found this file in the repo and noticed, that it has only one revision - 58.

I don't understand, why SVN complains about this file, when it is presented and why it points to revision 57 instead of 58 ?

I've also renamed the grand-grand-grand-parent folder of this file. Possible, this is an issue ...

Update

Detailed error description, that i've got from Cornerstone app (Mac OS X):

Description : Could not find the specified file.
 Suggestion : Check that the path you have specified is correct.

Technical Information
=====================

      Error : V4FileNotFoundError
  Exception : ZSVNNoSuchEntryException

Causal Information
==================

Description : Commit failed (details follow):
     Status : 160013
       File : subversion/libsvn_client/commit.c, 867

Description : File not found: revision 57, path '/trunk/assets/themes/base/article-content/images/logo-mini.jpg'
     Status : 160013
       File : subversion/libsvn_fs_fs/tree.c, 663

So, i've renamed "/trunk/assets/themes directory" to "/trunk/assets/skins", while improving project structure.

I've tried following:

  • updating /trunk/assets/themes directory
  • cleaning
  • deleting from filesytem and checking out again
  • reverting entire /trunk/assets/themes directory to the HEAD revision. Even this does't helps. Still getting the same error.

I've got no results.

share|improve this question
    
What does your log say? svn log path/to/your/logo-mini.jpg? – Lekensteyn Mar 6 '11 at 20:31
    
I cannot see a log for this file in my working copy, because it's grand-grand-grand-parent folder was renamed. AFAIK, it was sheduled for deletion and all files was deleted, leaving empty folders. – AntonAL Mar 6 '11 at 20:39
    
Figured out, what you mean. It says: r58 | AntonAL | 2011-01-23 16:00:56 +0300 (вс, 23 янв 2011) | 140 lines. Anyway, this is rev 58 – AntonAL Mar 6 '11 at 20:56
    
see update in my question – AntonAL Mar 6 '11 at 21:06
    
When i'm doing svn log --verbose, i see, that this file was added in revision 58 (r58) – AntonAL Mar 6 '11 at 21:21

Cornerstone requires that you manually set working copy version in Cornerstone that matches version of Subversion on server. You can change it by selecting Working Copy -> Upgrade Working Copy...

I've just figure out the dates in this post, but I'm gonna commit the answer anyway just in case someone is still searching for an answer

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .