Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I try to install a program I get the following error:

The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

I am running Windows 7 Ultimate - Version 6.1 (Build 7600).

I have tried the following solutions, to no avail:

  1. Go to services.msc and start Windows Installer
    When I try that, I get the error message:

    Windows could not start the Windows Installer Service on Local computer. Error 5: Access is denied.

    When I tried as Admin, I could not even open services.msc. It said:

    This function is not supported on this system.

  2. Deleting a second msiexec.

    When I went to C:\Windows\system32, there was no second msiexec.

  3. Modify Remote Procedure Call Service

    When I got to the Log On tab I was not able to choose Local System Account.

  4. Reinstall Windows Installer Service by downloading MSIServer

    After I merged the two files nothing changed.

  5. Install the latest Windows Installer version.

    I already have the latest version.

  6. Run regedit. Navigate through HKEY_LOCAL_MACHINE…SYSTEM…CURRENTCONTROLSET…SERVICES…MSIServer. Then right click on WOW64 and select “Modify.”

    When I got through the steps, there was no WOW64 for me to choose.

I do not know what else to try.

share|improve this question
    
Did you read all the related links in this article?...support.microsoft.com/kb/2438651 –  Moab Mar 6 '11 at 21:21
    
Possible duplicate...superuser.com/questions/19182/… –  Moab Mar 6 '11 at 21:22
    
I tried superuser.com/questions/19182/… and System already had full control. –  Rose Bierce Mar 7 '11 at 3:38
    
I even tried system restore but I got the following errors: Access is denied (0x80070005) The parameter is incorrect (0x800700057) –  Rose Bierce Mar 7 '11 at 3:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.