Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I unfortunately have to use Adobe Reader X on my Mac.

In the past, I could set Preview as the default PDF viewer in Safari, but with Adobe Reader X, that option is disabled!

enter image description here

I already know that I can delete Adobe’s plug-in, but I’m pretty sure it will just come back the next time the damn thing auto-updates.

The “right” way is to change that setting, which (at least in previous versions) maintained the setting through updates. How do I do it?

share|improve this question
    
It seems all solutions require root-access :-/ – ShiDoiSi Nov 6 '12 at 9:00
up vote 8 down vote accepted

It turns out this is a known issue. Adobe has a knowledge base article that says:

Known issues

Reader's Preferences > Internet > Display PDF in Browser is always dimmed

  • To disable Safari integration, delete the AdobePDFViewer.plugin from /Library/Internet Plug-ins
  • To reenable Safari integration, rerun the installer over the current installation. Start the Acrobat/Reader X installer from the original media, and then follow the onscreen prompts to complete the installation.

Hopefully the plug-in doesn’t come back the next time Reader updates.

share|improve this answer
    
Is there a way (e.g. hidden property) to "ungray" this preference setting? – Stephan Zehrer Sep 3 '12 at 16:32
    
Just an update if anyone stumbles upon this article. I'm running Reader 11.0.07 and the plugin to delete is /Library/Internet Plug-Ins/AdobePDFViewerNPAPI.plugin – user205336 Aug 18 '14 at 14:38

What I did was install a later version to reset it using the following steps:

1) Remover Acrobat Reader X 2) Delete plug (AdobePDFViewer.plugin) found at /Library/Internet Plug-ins 3) Go to http://get.adobe.com/reader/ 4) Press "Choose a different version" under "Select your version of Mac OS:" 5) Select your operating system & language 6) Choose & download Reader 9.4 NOT Reader X 10.0.1 7) Install Reader 9.4 7.1) Say no to the extension for safari plug in 7.2) Say no to request to set as default 8) Reboot your system & preview should return to the default

Optional 9) I removed Reader 9.4 using the unistaller found in utilities and then removed any remaining folders left in applications (there was one labelled Adobe)

Hope this helps

share|improve this answer
    
This could work but I want to stay current with the latest version. Thanks. – Nate Mar 21 '11 at 7:01

This question is already answered and a possible solution may be found in Adobe's knowledge base article as mentioned in @Nate's post.

However, a non-destructive method to disable Adobe Reader as PDF reader in Safari is to

  1. Create a new folder /Library/Internet Plug-Ins (disabled)/
  2. Move the file AdobePDFViewer.plugin-deactivated from /Library/Internet Plug-Ins to the newly created folder.

This way you don't have to reinstall Adobe Reader in case you change your mind later.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .