Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have USB drive and its file system is read-only ISO9660. How do I format it? It always says "Readonly FS"

share|improve this question

migrated from serverfault.com Mar 7 '11 at 12:04

This question came from our site for professional system and network administrators.

    
Is there a physical switch on the device? One that controls read/write ability? –  Tom O'Connor Mar 7 '11 at 11:02
    
No I don't think so,I checked it ,it don't seems to have a switch.I read on the web gparted might help - but it didn't even detect usb partition. –  lakshmipathi Mar 7 '11 at 11:15
    
Which OS is on the parent host? –  MadHatter Mar 7 '11 at 11:17
    
Im using Fedora 12. –  lakshmipathi Mar 7 '11 at 11:22
    
quick & dirty: "dd if=/dev/zero of=/dev/sdX bs=512 count=1", then recreate an MBR with fdisk or cfdisk and parition the way you want. Most likely it's you filesystem which is read-only and not the device. –  Shadok Feb 3 '12 at 17:06

2 Answers 2

If this is the only partition on this usb drive then it won't matter if we wipe the whole device. If that holds true you could create a new partition table using fdisk on the device. Once you have created a new partition table then create a new fat32 (if it's flash-based storage and you want interoperability between OS's) partition. If this is a platter based HDD then just choose the file system that works for you.

Here are some basic instructions on fdisk: Small FDISK Example from Ubuntu

The instructions can be fitted to your uses. Make sure you select 'o' to create the new partition table. This will wipe the references to the previous partitions and then you can just reformat the entire disk as whatever file system suits you. Let me know if you run into difficulties or creating a new partition table fails for some reason.

ONLY do this if you don't mind formatting the entire device (like a USB stick). If this is one partition on an actual HDD then you could try deleting and creating a new partition with fdisk and you could also try doing all of this from a LiveCD (just in case there is some setting somewhere in your OS that is preventing this).

share|improve this answer

It's possible that the issue is that ISO9660 FSes are read-only, rather than the drive. Let the drive mount, then type mount, and look for the drive's device:

/dev/sdb1 on /media/BigDrive type iso9660 (ro....

Then unmount the device (but don't physically remove it) and try reformatting it:

umount /media/BigDrive
mkfs.vfat /dev/sdb1

Note how I got the mount point (for unmounting) and the drive (for mkfs'ing) from the mount output above. It is really quite important to get those right, by the way, or you could destroy some fairly important data on your machine. Proceed with caution!

Assuming this works, remove and reinsert the drive, and it should show up as a usable VFAT FS.

share|improve this answer
    
Your advice did not work, because the filesystem is seems as read-only for system, even for root. Need some way to change the attributes of a filesystem on flash-drive, which the system defines as iso9660. –  user116695 Feb 3 '12 at 16:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.