Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this old kUbuntu box here, which used to be 8.04. For some reason after a bunch of upgrades and other unrelated changes sound doesn't work any more.

  • Sound works on this machine when rebooting to Windows, so it's not hardware problem.
  • It used to work on Linux on this machine before, so it's not weird hardware. (lspci says 00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2))
  • This problem persists across resets.
  • alsamixer etc. claims sound is not muted, and volume is high.
  • it's the same no matter which program I try to play some sounds (or which -ao for mplayer, default seems to be pulse)
  • nothing obvious shows up in system settings

Do I really need to reinstall the system to fix that, or is there something simple I'm missing?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

From 8.04 to 10.10, Ubuntu switched from Alsa to Pulse Audio. This cause a lot of problems with audio since some of the settings conflicted and drivers were a mess (at the time, it seems to have gotten better lately, although by no means perfect). This site may have advice for you:

Ubuntu Audio Upgrade Thread

This has a lot of advice on this exact situation. I'm not sure if this comes installed by default, but you can use the Pulse Audio Volume Control to make sure it's not muted. The command for that is "pavucontrol".

[EDIT]

In that thread it says it's not installed by default on Kubuntu... that's false as of the latest release, I believe. This site has more info on it: PulseAudio

share|improve this answer
    
Thanks, pavucontrol says it was muted for some reason. –  taw Mar 9 '11 at 4:08
    
No problem! Glad I could help! –  Vert Mar 9 '11 at 4:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.