Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just added a Windows 7 Pro computer to a network. All other computers are XP Pro and the Win-7 computer is supposed to be a file server.

At first, Win-7 set the network as "unknown network", because I don't have a dedicated Gateway. After just entering the IP of any of the other computers as the Gateway for the W7 computer, the network is now "workplace network", and file sharing should be possible.

But the computer is not visible to other computers and it cannot see other computers in it's network area.

I can ping back and forth using the IPs, but not using the computer names.

If I enter a IP / computername combination into the hosts file, then a ping to that computer name works, but that's not a good solution.

How can I make the W7 computer visible in the network?

share|improve this question
up vote 5 down vote accepted

Open the Network and Sharing Center. On the left side click on Change advanced sharing settings. You probably told Win7 that this is a Work network so click on Home or Work and then select Turn on network discovery and Turn on file and printer sharing. Click on Save changes and you should be able to see it from the other systems and see other systems on the network.

share|improve this answer
Both options were already enabled. – Holgerwa Mar 7 '11 at 14:29
@Holgerwa: Ok, is Windows Firewall turned on? It's been awhile since I did any work with it, but I believe there are some settings in there that could also cause your issue. – LeoB Mar 7 '11 at 14:36
Thank you! The firewall was the problem. Kaspersky is installed, and with the right settings, it works perfect. – Holgerwa Mar 7 '11 at 16:55
@Holgerwa: Cool! Glad I was able to help point you in the right direction. – LeoB Mar 7 '11 at 18:02

If Avast internet security is installed and firewall is active, it may cause the PC not to be seen on the network. You can try if it works after you disabled the firewall / Avast internet security.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .