Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have FreeBSD (test.local) box configured as NFS server. And I'm trying to mount its NFS sharing form my mac (hhmm.local)

/nfs     hhmm.local

/nfs has 777 permission.

And I checked from mac that it's working,

hhmm:~ Eonil$ showmount -e test.local
Exports list on test.local:
/nfs                           test.local
hhmm:~ Eonil$ 

But when I try to mount it,

hhmm:~ Eonil$ mount_nfs test.local:/nfs ~/nfs
mount_nfs: can't access /nfs: Permission denied
hhmm:~ Eonil$ 

Wow. I cannot figure out why this doesn't work. What should I do?

share|improve this question

I had the same issue with mount_nfs: can't access /: Permission denied on OS X 10.6.8 and even with the resvport option it still failed however modifying the nfs server export mount to use the insecure option worked.

share|improve this answer

I solved this problem with this blog post:

Core solution was giving an option resvport on mounting option. NFS volume mounted magically!

share|improve this answer
Was having this same issue; the resvport option works fine if you only plan on mounting via the CLI. If you want to mount via Mac OS X's finder, you need to add the insecure option on the server side, as @Cas mentions. There is no way to specify resvport via finder, and the ability to mount and use advanced options has been removed from "Disk Utility", so it seems as the server side fix is the only viable solution for GUI connecting. – Will Jun 22 '15 at 19:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .