Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently built a new computer, but my graphics card does not seem to be working properly. The Device Manager only sees the integrated graphics, although the fan on the card is working. I have tried moving the card to a different slot but no change.

I have an Asus P6x58d-E motherboard, and the graphics card is a sapphire HD 5770.

Does anyone have any ideas on how I can fix this?

share|improve this question
    
what is the wattage of your power supply? –  Kyle Mar 7 '11 at 16:58
    
Hi, it's 700W. Thanks. –  eldest_child Mar 7 '11 at 17:01
    
Did you connect a monitor to the card? I saw one ASUS post that said inserting the card would automatically over-ride the onboard, but it was connecting it to a monitor that made it work. Odd, but who knows, I would have assumed it was the bios as well. –  Dennis Mar 7 '11 at 19:32

2 Answers 2

Does this card need any 6-pin or 8-pin power leads? Make sure they're connected.

Are you sure the card works at all? Try it in another machine.

I'm not familiar with this exact motherboard, but there's also a slight possibility you need to disable the onboard graphics in the BIOS for the card to work. I would think on any X58 board it would be the other way around, though. (Even if that's the case, on most boards it should still SHOW UP, so that's kind of odd.)

share|improve this answer
    
Hi, Thanks for your response! I haven't got another machine to test the card in, so was hoping for some advice for ways to test it. I have tried looking in the BIOS for ways to disable the on board graphics but haven't managed to find a way to do it. Thanks –  eldest_child Mar 7 '11 at 17:11
1  
@eldest_child - Unfortunately, if it's not even showing up there's not much you can do to test it. Using a known-good slot, and making sure that the power leads are connected (this /is/ important...I think most 5770s need power leads!) is about all you can really do...beyond that, it's either a setting, or the card itself. –  Shinrai Mar 7 '11 at 18:50

as the @Shinrai suggest it is necessary to disable onboard graphics. i have also hd 5770 and intel dg41ty motherboard. my card was not working like you at first installation. look for the option where you can choose between IGP(integrated graphics processor) and pci-e. it must be in bios i can guarantee.

steps:1. first connect the motherboard to onboard graphics port. 2. go in to bios and look for option to choose between the two option, chances are that you will find this option in chipset configuration tab or something similar on your motherboard. choose the pci-e from that option. then save the option and exit bios. 3. do not restart just after saving the option. first shut down your pc by pressing the power button on cabinet. 4. now after shutdown connect the monitor cable to graphics card output port. 5. start the computer and now you should be able to get the display.

the same procedure i applied just 1 month ago.

you need to just look carefully the bios option of your motherboard. it is there for sure my friend.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.