Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a bit of a problem configuring my PuTTY client to work with the auto-completion feature in the ksh shell.

I do a listing on the root with the directories /home and /homeroot and it returns the directories in a list just fine. I can't select it, though, by hitting X = (where X is the number).

/home/nitrodist>ls /h        #hits esc + =
1) home/
2) homeroot/
                             #hits 2 + = for the 'homeroot' dir
1) home/
2) homeroot/
                             #hits just the '=' key.
1) home/
2) homeroot/

Any ideas? I've su -'d to another user who can actually do it with their PuTTY session and I can't do it there, which makes me think it's a PuTTY configuration issue. This is running on a ksh93 shell on HP-UX, if that makes any difference.

Here's my ksh config:

/home/campbelm>set -o
Current option settings
allexport        off
bgnice           on
emacs            off
errexit          off
gmacs            off
ignoreeof        off
interactive      on
keyword          off
markdirs         off
monitor          on
noexec           off
noclobber        off
noglob           off
nolog            off
notify           off
nounset          off
privileged       off
restricted       off
trackall         off
verbose          off
vi               on
viraw            on
xtrace           off
/home/campbelm>
share|improve this question

1 Answer 1

It doesn't have anything to do with PuTTY.

Try:

Esc = then 2 Esc =

or

Tab Tab then 2 Tab

share|improve this answer
    
Already tried the above line before and the second line was my gut instinct when I first started using ksh. Sorry, not at work until tomorrow to definitely test. –  Nitrodist Mar 7 '11 at 23:14
    
OK, just tried those commands and it definitely doesn't work. –  Nitrodist Mar 8 '11 at 14:00
    
@Nitrodist: The keystrokes I showed are for emacs mode. I should have asked whether you are using vi mode. What specific version of ksh (echo $KSH_VERSION)? Can you check to make sure the other user is using the same version? Your keystrokes work fine for me through PuTTY to a Linux system running 93t+. Are you using the regular number keys or the numeric keypad (try both)? –  Dennis Williamson Mar 8 '11 at 15:57
    
>echo ${.sh.version}; Version M-12/28/93e It's really bizarre. His version is the same. He had ignoreeof set to on in one case and it worked, and then ignoreeof set to off in another case which gave behavior similar to mine. So I set it to on but it didn't work. My numpad doesn't feature an equals key that works. –  Nitrodist Mar 8 '11 at 20:08
1  
Well, it looks like there is a version difference between the AIX and HP-UX servers that we were testing it on. Version E doesn't work at all but version T does. Also, my shell had been set to ksh instead of ksh93, leading to much more confusion. –  Nitrodist Mar 8 '11 at 20:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.