Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows 7 its easy to edit photo tags directly from the file properties dialog but the English version of Windows 7 uses a font in this dialog which does not support Japanese and other characters. (Such characters are displayed as boxes)

Is there a way to set a better Unicode font for the properties dialog?

share|improve this question
1  
Have you tried installing Japanese language packs for Windows? –  Shinrai Mar 7 '11 at 23:31
    
@Shinrai: Well I have lots of Japanese fonts and the Japanese IME installed. I can even see the tags when I'm entering them into the dialog, but not when they are just displayed statically! –  hippietrail Mar 8 '11 at 7:27
    
I figured you had, hence not bothering to actually make it an answer. Confirmation is good though. –  Shinrai Mar 8 '11 at 15:11

1 Answer 1

up vote 2 down vote accepted

There is no simple way to change it from the settings GUI, but you can change the default Windows font for all system dialogs in the registry.

  • Open regedit.exe as an administrator
  • Go to HKLM\Software\Microsoft\Windows NT\CurrentVersion\FontSubstitutes
  • Change the REG_SZ values MS Shell Dlg and MS Shell Dlg 2 to the name of the font you want Windows to use as the default. Note that this will affect all default Windows system dialogs, not just the one you're asking about. There is no way to change it for just that dialog.
  • Restart your computer or log off and back on to see the changes take effect.

I just verified this on my computer, and it does change the setting for the dialog you asked about. It also changes the settings for many other dialogs as well though, so make sure you use a font that will work with English as well.

share|improve this answer
    
Thanks. Of course the real problem is that the Windows GUI still doesn't do font substitution or fallback and most CJK fonts don't have accented Latin characters and most latin fonts don't have CJK characters. I'll have to dig up an old copy of Arial Unicode MS which does cover both. –  hippietrail Mar 8 '11 at 7:30
    
Yup, sorry that there isn't a better solution with the whole multilingual thing, but this should do the trick for you at least. –  nhinkle Mar 8 '11 at 7:34
    
Cool; that worked! Unfortunately it’s not quite enough. The Run dialog is not affected, (and the Start Menu and taskbars could use makeovers too) but I don’t see any relevant entries to change. (No, the Window Color and Appearance dialog doesn’t work either.) –  Synetech Aug 13 '11 at 17:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.