Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to give access to a website in IIS on my Win 7 machine to another person on my network. He's unable to access it. I was wondering if perhaps it was because IIS isn't configured to allow remote connections (I seem to remember having to do this sort of thing on Win XP).

I've hunted around in IIS and googled but am not finding a way to configure remote connections on Win 7. Some of the answers I've found seem to refer to Win Server 2008 and talk about a management service in IIS Manager, but it doesn't appear to be present on my machine.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Turns out it was Windows Firewall that was the culprit. I enabled domain access and now the website is visible to the other user.

share|improve this answer

To enable http access through Windows Firewall on Windows 7

From the start menu begin typing "Allow a program through Windows Firewall".

Scroll the bottom of the list and look for World Wide Web Services (HTTP) and enable it on your networks.

share|improve this answer
    
Thank you so much for this answer! –  Pavel Nikolov Jun 15 '12 at 15:09
    
after doing things chris marisic saied, you must open "windows firewall with advanced security" and find 3 rules started with "World Wide Web Services". then enable them –  user1441476 Jan 26 '13 at 6:40
    
this is correct answer –  Andrija Cacanovic May 19 '13 at 13:34
    
Thanks, bro! You're awesome. –  user973810 Sep 9 '13 at 18:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.