Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Google Chrome is crashing when I try to open it. I'm assuming that it's probably a bad extension that's causing the problem.

How can I start up Chrome with all extensions disabled / turned off?

share|improve this question

migrated from stackoverflow.com Mar 7 '11 at 23:16

This question came from our site for professional and enthusiast programmers.

8  
Not really relevant to Stack Overflow, but passing the --disable-extensions flag should do it. –  thirtydot Mar 7 '11 at 22:50
    
My issue ended up NOT being a typical extension, but rather Adobe Flash. The indicator was that the crash report showing nvSCPAPI.dll_unloaded was the issue. Re-installing flash from get2.adobe.com/flashplayer/otherversions fixed the issue and I was able to start Chrome again. –  user226795 May 25 '13 at 14:24

6 Answers 6

thirtydot is correct, run Chrome with the --disable-extensions command-line option to disable extensions.


Technically, it doesn’t so much disable all the extensions as much as hide them so that Chrome thinks that none are installed, so this won’t help in your particular case. t_b_b, since you cannot disable extensions in-browser and the command-line argument hides all extensions, what you want to do is to manually disable them. Open your User Data folder then open the file Preferences in a text-editor. Now scroll down to the line starting the settings blocks: "settings": { Each of the extensions will have its own block inside the settings block. To disable them, change their states to 0: "state": 1

To simplify things, just do a search for all lines containing

"state": 1

and change them to

"state": 0
share|improve this answer
    
Note that this doesn't seem to stick for me. When I edit Preferences it works fine the first time. If I then start/quit Chrome the states revert to their previous values. So I need to replace the Preferences file before each start. –  studgeek Apr 27 at 20:03
    
@studgeek, then you are missing something or modifying it while Chrome is still running (it reverts the setting when you exit) because this is how Chrome determines which extensions are enabled or disabled, and if didn’t work, then you would have to re-enable/disable everything each time you run it (when running normally), but clearly you don’t; it remembers which are enabled or disabled. Also, make sure you are taking extra care with things like commas because a missing or extra one will render the JSON syntax invalid which causes Chrome to ignore the file. –  Synetech May 11 at 2:19
    
Consider tacking on "--safe-plugins" for good measure. –  Pup Aug 1 at 22:58

Open an incognito window.

"If you want to create a shortcut that opens Chrome in incognito mode, duplicate an existing Chrome shortcut, right-click on the shortcut, select "Properties" and append this flag to the target value: --incognito (don't forget to add a space to separate the flag)."

Google Chrome Safe Mode

share|improve this answer
    
Despite what the linked blog says, Incognito Mode is not a replacement for Firefox's Safe Mode. –  dotancohen May 8 at 7:41

Run Chrome with commandline switch

--safe-plugins

This will run the plugin processes inside the sandbox and will not crash Chrome if you are sure that it is the plugins that are crashing Chrome.

share|improve this answer
1  
Handy, but plugins are different from extensions. –  Mu Mind Sep 22 '12 at 19:46

I tried all the suggestions for launching Chrome with plugins, no plugins, incognito and so forth... nothing worked. Even the menus launch a Chrome page, so if Chrome gives you the "Aw Snap" message, it really means - Aw Snap! You can't even get to the tools and settings.

I did a Ctrl+Alt+Del and found chrome.exe in the task manager. Then I forced it closed, Chrome finally came up again. It has something to do with syncing your Gmail account when Chrome launches: if that is failing, then Chrome turns into Chris Rock.

share|improve this answer
2  
"Chris Rock"? I'm not getting the reference. –  Al E. Oct 22 '12 at 17:15

You might need to delete the locally stored user profile. Try this:

  1. Open the window of the user you want to delete. (Check the icon in the top corner to make sure you're in the right user)
  2. Click the Chrome menu on the browser toolbar.
  3. Select Settings.
  4. In the “Users” section, select the user that you want to delete.
  5. Click Delete.

Alternatively, you can click the X icon to the right of the user. In the confirmation dialog that appears, click Delete.

share|improve this answer

Per http://peter.sh/experiments/chromium-command-line-switches/

--bwsi Indicates that the browser is in "browse without sign-in" (Guest session) mode. Should completely disable extensions, sync and bookmarks. ↪

share|improve this answer

protected by Community May 25 '13 at 17:16

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?