Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Usually if a program is running in, when you try to close it it will give you a warning "Do you want to close this Window?" This happens to almost everything that I have tried, including more, man, bash, etc. It gives you this warning even if you have suspended jobs.

The only exception is ssh. I can ssh into another machine and accidentally click the close button and would be happy to close it for me. Are there ways to change this behavior? Thanks.

share|improve this question
up vote 7 down vote accepted

You need to explicitly remove SSH from the permitted-to-close processes list in Terminal's preferences:

Terminal preferences

share|improve this answer
oh... that's easy, thanks! I don't understand this default setting though... – ceiling cat Mar 8 '11 at 2:46
It's the default presumably because most people consider that list of programs to be like shells, and killing shells without prompting is desirable to a number of users. But that does mean users have to beware about closing a terminal while there are remote processes running, since Terminal only knows about local processes. A number of ssh users typically start a screen session to keep the remote processes alive, so closing the ssh connection has no adverse consequences in this regard. – Chris Page Oct 25 '11 at 12:22
If you think the default should be different, as always, consider telling Apple. You can send a bug report (requires a free developer account) or use . – Chris Page Oct 25 '11 at 12:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.