Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got permission prob with first test project on gitosis server, ubuntu lucid server

Used this howto https://help.ubuntu.com/community/Git

changes, commits and push on gitosis-admin worked.

Then i created the test project and local repo and committed sth., set master as in howto but then on push i got:

ERROR:gitosis.serve.main:Repository read access denied
fatal: The remote end hung up unexpectedly

Maybe it's necessary to tell that we use NFS and I am not sure about how to handle the keys.

I saw that the key i put in /srv/gitosis/.ssh/authorized_keys had mylogin@server at the end. So I generated one on the new box i've been working on since tw weeks now and appended it to the file.

w/o.success - so I tried AllowUsers gitosis in server's /etc/ssh/sshd_config and restarted ssh server.

Now i am asked for gitosis@server's password: !!

Switched back but keeps asking.

Please give a hint how to check further. - Florian

share|improve this question

1 Answer 1

up vote 2 down vote accepted

gitosis is no longer maintained and supported by the author; most people usually recommend gitolite instead which has much better documentation and more features: http://github.com/sitaramc/gitolite

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.