Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I do have my work laptop at home and I want to share an USB printer in order to be able to print to it from my MacBook.

Currently Windows 7 is refusing to share the printer because the computer is part of a domain and it tells me that I need to join a homegroup in order to be able to do that. Also it tells me that he cannot create this homegroup and this group has to be create by another Windows 7 computer from my network. As you can imagine I do have only one Windows computer on my home network.

How can I solve this problem?

share|improve this question
add comment

4 Answers

You shouldn't need to use a homegroup to share printers. Just go to Devices and Printers (under the start menu) and find the printer.

  • Right-click and choose Printer Properties
  • Go to the Sharing tab
  • Check the box for Share this printer
  • Give it a share name
  • Click OK

Printer Properties Window (without admin rights)

I just set up Windows 7 on a domain in a virtual machine and tested this, and it let me share the printer just fine without being connected to a homegroup.

share|improve this answer
    
This is happening probably because you are a domain admin, something that I'm not. –  sorin Mar 14 '11 at 6:25
1  
You do not need to be a domain admin to install printers and setup sharing privileges for them; however, you do need to be a local administrator. If you are not an administrator of any type, you can still access that dialog box, but will have to elevate to an administrative account using UAC before you can change the settings. –  nhinkle Mar 14 '11 at 9:06
    
Sorry but I used my domain account, that has Administrative privileges on the local computer and it didn't worked, the sharing option had vanished. –  sorin Mar 17 '11 at 16:19
1  
Are you absolutely certain you're clicking on Printer Properties, not Printing preferences or Device Properties or anything like that? –  nhinkle Mar 17 '11 at 16:51
add comment

http://support.apple.com/kb/HT3049

This addresses adding it manually. Or can you use the print&fax utility?

share|improve this answer
1  
Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Tom Wijsman Mar 13 '11 at 15:22
add comment

You can simply switch between domain membership at the office and workgroup membership at home. These are two distinct configurations, so there is no reason to stay member of the office domain while you are at home.

You can do this manually, by using Alternate Configuration in the iPV4/6 Properties, or use one of the following free products which do much more :

Eusing Free IP Switcher
NetSetMan

NetSetMan has more extensive feature-set, and the free version can flip : IP Addresses, Gateways (incl. Metric), DNS Servers, WINS Servers, IPv4 / IPv6, WiFi Management, Computer Name, Workgroup/domain, DNS Domain/Suffix, Default Printer, Network Drives, NIC Status and SMTP Server.

image

share|improve this answer
    
I think that you are confusing network settings with domain membership. Currently my computer is configured to use DHCP and this works very well for both corporate and home configs. –  sorin Mar 13 '11 at 20:04
    
No confusion here. The IP address is distinct from the network, although this also is parametrable. I recommended these products for their ability to flip between domain and workgroup. See the feature list I added above for NetSetMan. –  harrymc Mar 13 '11 at 21:53
add comment
up vote 0 down vote accepted

I solved my problem by removing the computer from the domain :p

share|improve this answer
    
Well, isn't this exactly the solution I proposed ? In addition, I also listed some tools that can easily flip between the states where your computer is or is not member of the domain. –  harrymc Mar 17 '11 at 19:57
    
You removed your work computer from the domain? I'm sure that will go over well with your IT staff... –  nhinkle Mar 17 '11 at 23:52
    
I ordered an AirPort to solve this problem ;) –  sorin Mar 24 '11 at 22:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.