Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How to use (internal) PC speaker instead of external speakers for the "tput bel" sound? Which parameters should I change?

share|improve this question
    
possible duplicate of Enable System Beep in Ubuntu –  Dennis Williamson Mar 8 '11 at 15:21
    
@Dennis and the original poster: It may depend on the distro. –  oKtosiTe Mar 8 '11 at 16:02
    
This may also be kernel dependent - I don't have a pcspkr module under 2.6.37.1... –  new123456 Mar 9 '11 at 11:58
    
To get the internal speaker to work, you need to load the module, but I believe it has been renamed to snd_spkr from pcspkr. To get the internal speaker to catch the regular PC speaker signal, there might very well be some OS specific setting. –  Daniel Andersson Apr 2 '12 at 7:38

2 Answers 2

Debian has the 'beep' package. It beeps the speaker, no soundcard needed.

The upstream page is here

share|improve this answer

Check your BIOS settings. If the pcspeaker is disabled there, as it is often the case, you won't hear anything no matter what.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.