Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use a windows7 ultimate operating system. For some time i've been unable to set up an ad-hoc network. Each time I try, it displays "Windows could not set up 'NetworkName' ". Pls, I need suggestions on how to solve this problem. Thanks

share|improve this question

migrated from Mar 8 '11 at 15:53

This question came from our site for professional and enthusiast programmers.

Make sure your wireless hardware switch is turned on, you can't imagine the relief I got after finding that out.

share|improve this answer

Did this work and no-longer works? Or has it never worked properly?

That said somethings you should probably know:

  • The ad-hoc part of the 802.11 standard (wireless) is very poorly implemented by some wireless network device manufactures
  • AdHoc does not support WPA, and many vendors have issues with using WEP on AdHoc
  • It might be preferable to use something like Virtual Router or Connectify which would allow you to make an infrastructure (normal wifi) network using a Windows 7 Host
share|improve this answer
AdHoc supports WPA2, get your facts straight. The 802.11-2007 and 2012 standard clearly specifies how to use RSN in IBSS mode. Whether it is implemented is another thing (if you wanna try, Linux supports IBSS RSN on more devices than windows). – BatchyX Nov 9 '12 at 15:42
Virtual Router worked instantly after I failed to get my ad-hoc network working. Thanks. – Julian Mar 17 '13 at 20:23

Make sure your wireless is on. I kept getting that message again and again until finally I realized that my wireless was off the entire time.

share|improve this answer

to elaborate slightly - make sure the hardware switch for your wireless is turned on - not just enabling the network adapter in windows - a nice palm to forehead moment for me.

share|improve this answer

It worked for me, but I had to let Windows manage the WIFI and not another program such as the ones delivered with the WIFI hardware!

share|improve this answer

You must log in to answer this question.