Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ever since I created a couple of macros in Excel for Mac 2011, the Personal Macro Workbook opens every time I open Excel. How do I keep that from happening?

I have since deleted the macros, but I still get the workbook popping up every time I open the program. It's an annoyance, more than anything, but one I'd like to eliminate.

share|improve this question

5 Answers 5

up vote 3 down vote accepted

On Outlook 2010 for Windows you can hide a given workbook (View tab, Hide) and it stays hidden when you restart Excel. Try that.

share|improve this answer
    
Woo-hoo! You're brilliant, Paul. I opened Excel and went to the Window menu and selected Hide. Then I quit Excel and saved the changes to the Personal Macro Workbook. When I next opened Excel, the template chooser popped up instead of the PMW. Thanks for the suggestion! –  Stuart Maxwell Mar 11 '11 at 16:19

The solution regarding deleting the macro workbook worked for me, but the instructions need to be adapted for the Mac (the poster is referring to Windows, but the OP asked about Excel 2011, which is a product for the Mac).

The file path containing the personal macros workbook on the Mac is:

/Users/[your user name]/Library/Application Support/Microsoft/Office/Excel

Removing the personal macros workbook from here solved the problem of Excel showing the personal macros workbook every time that Excel 2011 starts.

share|improve this answer

While viewing the Personal workbook, go to Mac's Excel 2011 "Window" in the menu bar and it should show that Personal is checked. If not, check it. Then use Hide in that same menu. This works through a restart.

Gleaned from source: https://answers.microsoft.com/en-us/mac/forum/macoffice2011-macexcel/excel-for-mac-personal-macro-workbook-locked-for/e9727ba3-7e9f-41dd-875b-6c304388968c

DO NOT DELETE the Personal workbook. It contains your macros and all kinds of stuff. Deleting it will cause Excel to make a new one but your macros won't be there. Yes it will make Excel not show it, but only because the default for Personal is to not show it.

I also see that the OP Stuart posted this earlier, but it was a short sub-entry so I didn't see it until after posting this. I would have deleted my post but I thought the reason for not removing the Personal workbook should be noted.

share|improve this answer

I had the same problem, but the solution above didn't work.

I found that some Excel add-ins were preventing me from hiding to the personal macro workbook.

After I disabled them, I retried the steps above and everything worked great.

share|improve this answer

With my upgrade to 2013 Office Pro I started having the same issue when opening an Excel file from the network. I did unhide on the blank instance of Excel and it was the personal workbook. After saving all my VBA scripts as notepad++ files I deleted all the modules.

This did not help either, however, now that I no longer need the personal workbook in VBA I deleted the file from my system. Path C: Users > "User ID Here" > AppData > Roaming > Microsoft > Excel > XLSTART: Personal

Now when I open Excel files from the network, or double click, the app opens only 1 instance.

:-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.