Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with booting from a USB flash drive. I have Acer TimelineX 3820TG. I have Windows 7 Home from Acer and I installed Mandriva OS from USB(from USB because this Acer doen't have a DVD drive). It was OK, but I want reinstall Windows 7 and so I did. Now I have Windows 7 Professional and it wrote over Mandriva's GRUB.

It wasn't a big problem. For a while I was just using Windows 7 but now I am thinking that I need some OS with Linux and I am thinking about Ubuntu. But when I tried to boot from USB with Ubuntu I get a black screen with a blinking cursor after the BIOS POST.

I was trying many applications to create a bootable USB drive and many versions of Ubuntu (and other Linux distributions), but nothing worked. I tried to Google for answers but I found many problems where all booting goes to black screen but in my problem Windows 7 boots fine from disc but from USB doesn't work.
Can anyone help me?

share|improve this question
up vote 3 down vote accepted

Just to make sure I'm getting the right question:

  • Your computer is an Acer TimelineX 3820TG, which as a mobility unit has no optical drive
  • The computer shipped with Windows 7 Home Premium
  • You wiped it with Mandriva which you installed sucessfully via USB
  • You decided you didn't like Mandriva and reformatted the computer with Windows 7 Professional, also from a USB Key
  • You decided that you'd like to dual boot with Ubuntu/
  • However after multiple attempts to create a USB Install disk, including using the Universal USB Installer, you can't get the machine to go past the blinking cursor

It sounds like your flash drive may be the issue here and it may need to be re-paritioned.

Did you try checking the Erase flash drive box in the U-USB Installer?

share|improve this answer
Yea, you are getting right and I tried erase. I will try other flash drive. – Bibo Mar 8 '11 at 18:45
Problem was with flash drive, when I use another It worked normal but I have another problem and create for it new question. – Bibo Mar 9 '11 at 6:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.