Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've setup my router to forward port 80 through to my computer, so I can access it from a dyndns.org domain. The domain and the ip both seem to be totally working, externally (can access it from outside the LAN). Unfortunately, I can't access it locally (on the LAN, or on the machine itself).

This is a "loopback error", I understand. I've set up port forwarding, and sifted through all the advanced settings I can find on the router. I really don't want to resort to using /etc/hosts files on local machines, but I guess I'll do that if I have to.

My router is an "EchoLife HG556a", a re-branded router that comes with a Vodafone Internet contract here in NZ. When log in in "advanced" mode, I see that the firewall log gets these messages whenever I try to access the mydomain.dyndns.org domain, or even hit it with the external ip directly:

Mar 9 16:36:24  kernel  warning     kernel: [fwlog] Bad source(not br0) packet attack, SRC=192.168.1.2 DST=203.118.175.161.
Mar 9 16:36:25  kernel  warning     kernel: [fwlog] Bad source(not br0) packet attack, SRC=192.168.1.2 DST=203.118.175.161.
Mar 9 16:36:26  kernel  warning     kernel: [fwlog] Bad source(not br0) packet attack, SRC=192.168.1.2 DST=203.118.175.161.
Mar 9 16:36:27  kernel  warning     kernel: [fwlog] Bad source(not br0) packet attack, SRC=192.168.1.2 DST=203.118.175.161.
Mar 9 16:36:28  kernel  warning     kernel: [fwlog] Bad source(not br0) packet attack, SRC=192.168.1.2 DST=203.118.175.161.
Mar 9 16:36:29  kernel  warning     kernel: [fwlog] Bad source(not br0) packet attack, SRC=192.168.1.2 DST=203.118.175.161. 
Mar 9 16:36:31  kernel  warning     kernel: [fwlog] Bad source(not br0) packet attack, SRC=192.168.1.2 DST=203.118.175.161.
Mar 9 16:36:34  kernel  warning     kernel: [fwlog] Bad source(not br0) packet attack, SRC=192.168.1.2 DST=203.118.175.161.
Mar 9 16:36:35  kernel  warning     kernel: [fwlog] Bad source(not br0) packet attack, SRC=192.168.1.2 DST=203.118.175.161. 

What's "br0"? Can I disable the requirement for traffic to be from br0? Any ideas what could be causing this? Or tests I can do to better understand what's happening? I'm running OS X 10.6.

EDIT: I tried disabling the DoS protection: no luck. Here's a good question and answer which explains what's going on I think. It seems my router doesn't support "NAT loopback", which isn't too surprising for a consumer grade device.

EDIT 2: I figured out how to log in to the router via telnet. For me, the u/p was admin/VF-NZhg556 which is different to other countries (i live in NZ). Via telnet I can execute iptables, which is promising.

share|improve this question
2  
NAT reflection is essentially what you want in this case. It will let computers on the LAN access the router and the port forward as if it were coming from off the LAN. –  MaQleod Mar 9 '11 at 5:54
    
Thanks MaQleod! I'm unfamiliar with NAT reflection. Assuming it's possible to set up my router to do this, how would I go about that? –  aaaidan Mar 12 '11 at 4:20
    
Shazam! I have telnet access, including iptables! What sort of command should I execute to setup NAT reflection? –  aaaidan Mar 12 '11 at 5:00
    
Mate, did you manage to solve this? Having the same headache here.. –  Dmitry Selitskiy Oct 28 '11 at 11:46
    
@DmitrySelitskiy, nah I got discouraged since it seems to be a bit of a black art. If I knew (or wanted to know) how to wield iptables, it'd be a different story. –  aaaidan Oct 29 '11 at 23:10

1 Answer 1

To answer the question about what "br0" is: Any interface that starts with the letters "br" is normally a bridge interface. That is, it's not a physical interface, but a virtual bridge between multiple interfaces.

As an example, a bridge interface could be used to serve a common subnet over two separate NICs (Network Interface Cards).

share|improve this answer
    
Cheers, that makes sense. I guess that's the ethernet-wireless bridge. Now as to why the source isn't from the bridge, since it totally is... –  aaaidan Mar 9 '11 at 4:10
    
Make sure your router's firmware is up-to-date, if you can. Sometimes strange routing problems are resolved this way (this is a long-shot though). –  Randolf Richardson Mar 9 '11 at 4:12
    
Thanks - I will look into that. Not hopeful though: modem just arrived in the mail. But who knows? –  aaaidan Mar 9 '11 at 4:21
    
It is actually not uncommon for a device to arrive with outdated drivers/firmware. It is a good idea to check for updated software for every device you buy. –  MaQleod Mar 9 '11 at 6:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.