Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use remote desktop on my laptop (running Fedora) to my desktop (also running Fedora) on the same local network.

I configured Remote Desktop on my desktop via System -> Preferences -> Remote Desktop, verified that the port is open by nmap, and attempted to connect from my laptop via vinagre (also tried appending :5900 for the port, and using the ip address). In all cases, the connection fails with a popup that says "Connection closed\n Connection to host was closed."

EDIT: I am able to use vinagre from the desktop to remote desktop into itself, just not from one machine to the other. I tried vncviewer and a similar problem occurs (unable connect to socket: No route to host (113))

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

It sounds like the firewall settings on your desktop (the machine you're trying to connect to) have not been configured properly. Use the Firewall Settings tool (System > Administration > Firewall) to ensure that you have TCP port 5900 open. Start the tool, choose Other ports, and verify that TCP 5900 is in the list. If it's not, add it, and try your process again.

(Also, the port worked from the desktop machine to itself because the loopback network device is already trusted by the default firewall configuration.)

share|improve this answer
add comment

Open the ports for the VNC Server in the remote machine:

sudo firewall-cmd --add-service=vnc-server

sudo firewall-cmd --permanent --add-service=vnc-server
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.