Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A small network of 2 Macs and 2 Windows XP machines using an Airport Extreme. One Windows machine stopped being able to connect. The wireless card had stopped working (unable to find any networks, no light); I replaced it, it found a strong signal from the airport extreme. I set up the WPA2-PSK encryption, and it claimed to be connecting, and stopped at the “waiting for IP address” stage. The router logs showed it connecting, then “deauthorizing” and disconnecting. I tried or checked:

  • Recreated the network profile, both in Windows wireless configuration and in the Linksys wireless utility
  • Used Nirsoft’s wireless key view on the PC that was still connected to the network to confirm the WPA key
  • Reinstalled the card drivers
  • Installed the peer networking option under advanced in the network connections window
  • Ran the connect to a network wizard
  • Checked that the router did not have MAC address filtering enabled
  • Ensured that the router did have sufficient IP addresses available in its DHCP configuration
  • Turned off the problem machine's firewall
  • Installed a 2Wire USB wireless card, which had the same problem
  • Tried to ping the router with no success

I think that's all. Any ideas?

share|improve this question

closed as too localized by Oliver Salzburg Aug 13 '12 at 16:47

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you go as far as to change the WPA key to something else and then update all the other clients? –  Mark Aug 19 '09 at 12:27
add comment

8 Answers

Often, when you try to connect to a wpa network with an incorrect key, it will show a "connection" but fail to recieve an IP address. This can be misleading, since the wifi appears connected and authenticated, and that the problem lies with DHCP, when in reality, the WPA key is at fault.

I have this problem all the time when I connect a new or unknown pc to my home network. I think I remember the key, and try it, and then it fails to get a DHCP address. Setting a new WPA key on both ends always solves the problem.

Change your WPA key to a guaranteed known key, and try connecting again.

Barring that, try connecting and setting a static IP address that's outside your DHCP range, with a subnet mask of 255.255.255.0 and a default gateway equal to your routers IP address (192.168.1.1?). DNS will be the router's address too. Try pinging the router, and then you'll know if it's a connection issue or a DHCP issue. I'm sure it's not relevant but a recent windows update somehow hosed DHCP on a buddy's pc, and he's been stuck using static IP's for a few weeks.

share|improve this answer
add comment

Have you tried removing all the security and using the defaults to see if the computers will connect? Also, make sure that the new wireless card that you got to replace your old faulty one supports WPA2.

share|improve this answer
add comment

1) I assume you loaded the WPA2 update for XP (it's old but at the time of release it was an optional update)?

KB893357

If you have KB893357 loaded continue on, if not, that is your problem.

2) Depending on the wireless software in use from time to time it will save the original key used to connect to a given ssid and won't overwrite it meaning you never truly authenticate. To be honest, I'm not sure how to clear it, but renaming the network ssid resolves the issue as well.

--As another person pointed out, also be sure MAC Filtering is OFF as you don't need it anyways (it's easier than easy to bypass).

share|improve this answer
add comment

Additionally to the already described (possible) solutions, there might be a MAC filter on the Router. The solution would be to add the MAC address of the new Device to the "allowed MACs" list.

You'd find the address with ipconfig /all in the command shell.

share|improve this answer
add comment

I had a similar problem when I first purchased my Airport Extreme. I could connect with my MacBook in OSX but not in XP. The issue was resolved with a combination of Windows Update in Windows, and updating the firmware on the Airport Extreme through Software Update in OSX.

Note: that I did both of these at the same time, so I'm not sure which of the two actually solved the problem.

share|improve this answer
add comment

Try changing the encryption method to WPA-PSK (TKIP) if it's supported. This is the 'safe' bet, as the widest array of devices can successfully connect to it. I've seen a lot of stuff that was supposed to connect via WPA2 (like netbooks and whatnot) just give up the ghost and not connect. Dropping the encryption back to WPA-PSK TKIP solved the problem.

share|improve this answer
add comment

Check that u installed all the protocols in that machine , and if nothin happened try to Remove it from the Device Manager ( Right click > Delete , restart your computer ) , if nothing works , Reset your router and don't use encryption and try , tell me what happens.

share|improve this answer
add comment

For those who were wondering: The router was set to WPA/WPA2 encryption (accept either one). When the cards weren't working they were both set to use WPA2. I changed encryption on the cards and router to WPA only and everything worked.

share|improve this answer
add comment