Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just moved to a new accommodation where I've got a WiFi (802.11g) router (Huawei EchoLife HG520i) right in 7 meters from my desk, so the signal is excellent (as reported by software).

But despite excellent signal, the connection tends to break very frequently (automatically reconnecting immediately though, but still annoying by breaking VoIP conversations and causing browser "Server not found" errors from time to time). What may the reason be and how to fix this? What link parameters I should try finetuning in the router and/or in the computer's WiFi adapter driver?

I've got no problem with other WiFi networks, so I believe my laptop's WiFi adapter to be Ok.

share|improve this question

4 Answers 4

You may be suffering intermittent interference from other external devices, such as other people's nearby routers, DECT telephones, etc.

Try configuring your router to use a different WiFi channel.

This Wikipedia article contains some nice information about the ISM spectrum and possible sources of interference, and this one has even more detail specifically about 2.4GHz.

share|improve this answer
1  
Channel 11 is recommended. –  harrymc Mar 10 '11 at 10:23

On your laptop check the channel of the other Wifi routers in range. Now in your router's config, pick a channel different from them. Also if you haven't switched to WPA/PSK encryption yet, then do so.

Beyond the above, I can think of Windows' native Wireless driver. I've had problem with it in the past, it'd find my router and then drop the connection. Now I use my vendor's own driver & software (e.g. Intel, Linsys...) for detecting and pinning that wifi connection. No problem since!

share|improve this answer

Well if it is only 7 meters from your router, I would recommend using a cable.

Otherwise here are few solutions:

  1. Update your router firmware.
  2. Be sure that there no electrical devices around your router.
  3. Check the router channel, the most common people is Channel 1, so change it to a different one. To select a good channel check which one is not used by other wifi spots.
  4. If possible check other routers settings(which don't cause disconnecting) to compare with your router.
  5. Try tinkering with settings, check if it drops without any WEP/WPA, don't hide your network.
  6. To check for sure if it is the routers fault, just swap router with one of your friends. Or ask your friend to bring his laptop and check if it drops for him.

Few other websites to search for a solution: http://www.pcmag.com/article2/0,2817,1568517,00.asp http://compnetworking.about.com/od/wifihomenetworking/tp/connectiondrop.htm

share|improve this answer
    
Due to channel overlap channels 1, 6, and 11 are good choices. Normally you want to get off of channel 1. –  BillThor Mar 10 '11 at 15:29
    
"the most common people is Channel 1" - the most common set-up is automatic channel switching as my experience shows actually. –  Ivan Dec 26 '12 at 20:37
up vote 0 down vote accepted

The problem seems to be the particular hardware models (Huawei EchoLife HG520i modem/router/AP and Intel Ultimate N WiFi Link 5300 NIC) incompatibility. I can conclude this as I never have the problem with any other access point but always experience it whenever try working with a modem of the same model (they are quite popular in our location) and I never have the problem with this modem as lon as I use a different WiFi NIC (a PCMCIa one based on a different chip).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.