Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am signed in under an administrator account in my laptop; however, now vista is not allowing me to install / uninstall any software.

share|improve this question

migrated from stackoverflow.com Mar 10 '11 at 12:25

This question came from our site for professional and enthusiast programmers.

    
We're definitely going to need more details than that in order to help you with your problem. What type of software are you trying to install/uninstall? How have you tried to install/uninstall it? etc. –  Cody Gray Mar 10 '11 at 10:46
    
Thank you Cody for your quick response. I was able to install any software before. Now I tried Firefox. I am not able to run McAfee virus scan –  Razack Mar 10 '11 at 10:55
    
One more symptom is even though connected to electric power some times it is showing as though running on Battery. –  Razack Mar 10 '11 at 11:04
    
What happens (error messages, etc.) when you attempt to install software. Also, sounds like the power jack in your laptop has become disconnected from the board and needs to be resoldered, or your charger is bad. –  ultrasawblade Mar 10 '11 at 13:16
    
@Razack Is the administrator account logged in as Administrator when you look at the account name? Or is it your name with Administrator privileges? –  paradd0x Mar 10 '11 at 20:02

2 Answers 2

up vote -3 down vote accepted

Since you are running under your username with Admin privileges, Windows Vista does not really give you privileges to run stuff. To access the administrator account and install software and stuff you need to access the hidden "Administrator" account.

Go to the command prompt icon and right click and hit "Run as Administrator"

Type in the following command:

net user administrator /active:yes

Reboot your computer to apply the changes and you now have access to the real admin account.

To turn off this administrator account, run the same command but instead of yes, say no.

share|improve this answer
    
Thanks: this works –  Razack Jul 4 '11 at 6:45
1  
This answer is completely incorrect. Every administrative account has full admin privileges. There is no need whatever for the builtin Administrator account. The question asker (and others) need to learn about Vista's User Account Control and its Admin Approval Mode. –  kreemoweet Mar 30 '13 at 21:38
1  
Apparently this worked for the OP. However, feel free to post a better, more detailed answer, referencing this answer and why its incorrect, both so that you can set the record straight properly (and get some reputation in the process!) and so that others can benefit from the explaination. –  Journeyman Geek Mar 31 '13 at 3:43

Go to the software's main .exe file or .exe shortcut. Mainly they are saved in Desktops.

Right Click That file -> Properties-> Security(Tab)

Under "Groups or usernames" section, click on the type you have logged in as. Imp Don't click Administrators, try the second option which will be below "SYSTEM".

Now click "Edit" -> Select the same option which you've selected -> Under "Permissions" -> Select Full Control. Apply this and save it.

Now goto Control Panel and try uninstalling that software again. :-)

share|improve this answer

protected by Breakthrough Mar 31 '13 at 5:16

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.