Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The short story:
Win7 lost track of my user folders location (desktop, my documents, my pictures etc...). They now reside on a different partition. How can I relink these folders?

The long story:
The way I partition my drives is:

  • C: - SSD drive for Windows and Program Files
  • D: - A large regular hard drive for all my user data

The first thing I do after a fresh Win7 install is move my user folders to D:, by right clicking on these folders under C:\users\username\, choosing the Location tab and clicking on Move.

I've just completed encryption of D: using TrueCrypt. It shows a lot of warnings before the encryption process, but (hrrmm...) it does not mention the fact that after encryption the data is located on a new drive letter, say E:

This broke Win7's links to my special user folders. How can I relink these folders?

share|improve this question

2 Answers 2

After the encryption, the drive is no longer recognized by Windows 7 and it usually asks you to format the drive. You then have to mount the drive with Truecrypt and assign a drive letter to it, in your case E:

To relink the folders, do the same process that you applied to the D: and use E: instead or whatever you have set for the drive.

The files and folder structure are all still the same, the only major change after encryption is the drive letter. Anything that referred to D: must now be changed to refer to E:.

There are also some registry tweaks available but most people are not comfortable in changing those.

Here is the registry path to the User Shell Folders.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
share|improve this answer
    
Thanks @klutch2, but I don't have user folders in the original location anymore, I only have them on E:. And as Win7 doesn't recognize them as user-folders, they don't have Location tab, so I can't do the same process as you suggest... –  Jonathan Mar 10 '11 at 21:47
    
There are registry changes, as I mentioned, that allow you to set the default user folders location to, in your case, the E: drive. –  paradd0x Mar 10 '11 at 21:50
    
Can you accept the answer if it worked for you please? –  paradd0x Mar 11 '11 at 16:28

All it took was going to the correct registry entry, changing all the location from D:... to E:... for each and every user folder and reboot.

As klutch2 mentioned the registry location is:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

The registry key names are not always trivial, for a full list (and a much more complicated explanation) see here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.