Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Everything else is configured. When I turn the firewall off, it connects. When I turn it on, it doesn't. I've added inbound and outbound rules, opening port 21 for all programs and services, but it's not good enough. Why??

share|improve this question
It looks like this has been answered over on ServerFault already. -… – goblinbox Mar 11 '11 at 1:29

FTP uses 2 channels for communication, ftp-data (20) and the ftp control channel (21). Depending on how you have it configured, active or passive, it will require a different configuration.

Windows makes things easier due to the fact that you can allow certain executables instead of specific ports. You can choose to allow the FTP server executable, or put the server into passive mode and allow ports 20 and 21.

share|improve this answer
The server is running as a service. I've now opened 20-21, but nothing. What's this about passive mode? I'm using zFTPserver. – Mica Mar 11 '11 at 3:31
Ok, now I've made it as open as possible, allowing any protocol on any port for the service, on both the inbound and outbound rules. It still won't work! – Mica Mar 11 '11 at 3:44
@xichael: don't forget you might have to open both TCP and UDP connections for those ports. – KdgDev Mar 17 '11 at 11:07
Both TCP and UDP were opened... I never did end up getting the Windows 7 firewall to work (even after reinstalling Windows) so I went with Comodo Firewall instead, and haven't had any issues. – Mica Apr 25 '12 at 5:13
I have the same problem - I can't get the firewall to allow incoming FTP; if I disable the firewall FTP works fine. – bgmCoder Feb 4 '15 at 4:07

This is where the answer lies. Step 2 has a corresponding rule in Windows Firewall Advanced Settings (which you might tweak further), but I cannot find the rule for step 3 there.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .