Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm so used to using C-a for the home key (based on my being an emacs nerd) that it bothers me that this is the combination that screen uses to start commands. Can I bind something else to it?

share|improve this question

4 Answers 4

up vote 3 down vote accepted

The C-a combination can be remapped from the .screenrc file, with the bind command.

This website should be a huge help to you: http://www.softpanorama.org/Utilities/Screen/screenrc_examples.shtml

share|improve this answer

From my own .screenrc :

# replace Ctrl-A with Ctrl-O
escape ^Oo
share|improve this answer
    
+1 because that's exactly what I use. –  Doug Harris Sep 2 '09 at 20:01
    
I use Ctrl-Z personally, because that's the least frequently used key in Emacs, at least for me. –  Teddy Oct 24 '09 at 21:43
3  
But Ctrl-Z is used in the shell to suspend jobs - so not ideal imo. –  GodEater Oct 28 '09 at 9:17

From screen's man page related to the -e option:

       -e xy
            specifies the command character to be x and the character generat-
            ing a literal command character to y (when typed after the command
            character).   The default is "C-a" and `a', which can be specified
            as "-e^Aa".  When creating a screen session, this option sets  the
            default  command character. In a multiuser session all users added
            will start off with this command character. But when attaching  to
            an  already  running session, this option changes only the command
            character of the attaching user.  This  option  is  equivalent  to
            either the commands "defescape" or "escape" respectively.

share|improve this answer
    
Sigh... when in doubt, check the man page. :-/ –  Jason Baker Aug 22 '09 at 14:40
    
Could you put an example of invocation? –  ssice Jan 12 '13 at 18:56

It helps to go through the menu. :-/

I changed it by hitting F9, and selecting "change escape sequence."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.