Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason, whenever I go to a WebGL demo site, I get a message saying my browser does not support WebGL...

What is going on?

I have Chromium 11 installed on MS Windows XP Pro

share|improve this question
1  
Actually I've just tried Google Chrome (v10) on XP and both khronos.org/webgl/wiki/Main_Page and bodybrowser.googlelabs.com are reporting that I don't have the necessary kit. –  ChrisF Mar 11 '11 at 17:04

3 Answers 3

up vote 3 down vote accepted

@ChrisF,

2 things (I work on GPU acceleration in Chrome)

1) XP systems are usually older machines. Most users don't upgrade OSes or drivers, so the drivers on XP systems are often very old. We'll be re-enabling GPU-acceleration on XP for people with up-to-date drivers, but unfortunately not everyone is able to update their drivers.

2) XP driver bugs are more catastrophic, see: this MSDN article which explains Windows Vista/7's driver model. In XP systems, a buggy driver can bring down your entire system (BSOD). In Vista/7, issues are usually contained to a process crash, which in Chrome will most likely just bring down the tab.

share|improve this answer

I've just found this on Google support forums

On Windows XP, GPU acceleration is now blacklisted. If you want to enable http://code.google.com/p/chromium/issues/detail?id=72975

You can re-enable WebGL and Accelerated Compositing by using --ignore-gpu-blacklist startup switch.

I can verify that setting this flag in the shortcut used to start Google Chrome works and http://bodybrowser.googlelabs.com/body.html works on my XP machine with a nVidia GeForce GTS 250 graphics card.

I haven't been able to find a definitive statement on why it's blacklisted though.

share|improve this answer
2  
because on XP systems, using the GPU functionality causes a lot of crashes and hangs, so they disabled it by default to prevent problems for novice users. The option can be manually added by advanced users since they are presumably advanced enough to understand the risks. (They’re restoring the default-on setting for XP systems with up-to-date drivers in Chrome 11.) The real question is why it’s so unstable on XP; video drives are much more stable on XP. –  Synetech Mar 11 '11 at 19:59
1  
@Synetech - thanks. I did mean to dig further to see if I could find the reason behind the change. –  ChrisF Mar 11 '11 at 20:04

Which webpage are you visiting to test WebGL?

Does this page work for you? http://www.iquilezles.org/apps/shadertoy/

My guess is that it's the webpage, not the browser.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.