Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to play a DVD in Media Player Classic, when I get the error DVD: Copy-protection fail.

What can I do to play my DVD? Preferably in MPC.

I'm running Windows 7. It works in Windows Media Player, but as it doesn't give me as many configuration options as MPC, I'd prefer to use MPC. And of course this is a genuine DVD, as this only affects us poor suckers that actually buy DVDs :(

share|improve this question
    
Does it work in other players? Is it a pirated dvd? You didn't even tell us what OS you are using, some details might help. –  Kyle Mar 11 '11 at 18:29
    
Sorry, updated the question. –  Znarkus Mar 11 '11 at 18:34
    
Great update! thanks, I wish I could help you but it has been so long since I last used MPC. –  Kyle Mar 11 '11 at 18:35
    
Feel free to recommend another software where this works, that is otherwise comparable to MPC :-) –  Znarkus Mar 11 '11 at 18:37
    
Seems a valid question to me, voting to reopen. –  BloodPhilia Mar 14 '11 at 14:52

4 Answers 4

Since you are fine with a recommendation I personally use VLC media player as my de-facto program for playing and streaming any media. I haven't run into much it can't play, in fact I have never run into anything Windows Media Player can play that VLC can't. It is also one of our featured programs if you check out the community promotions on the right.

share|improve this answer
    
Tonight it magically just worked. Don't know what I did different. Maybe it was because I started the video when the movie window was on the projector screen, instead of moving it there afterwards. Maybe because I skipped right to the movie. Feel kinda stupid, voting to delete question. Thank you anyway! –  Znarkus Mar 12 '11 at 20:17

The Media Player Classic FAQ says :

Q: I get a "DVD: Macrovision Failed" error when trying to play a DVD

A: This may happen if you have are using Haali video renderer.
Solution is to change the video renderer in MPC options.

MPC options -> Playback -> Output

Apart from this, you may try updating the video driver from the manufacturer's website, or abandon MPC.

share|improve this answer
    
Tonight it magically just worked. Don't know what I did different. Maybe it was because I started the video when the movie window was on the projector screen, instead of moving it there afterwards. Maybe because I skipped right to the movie. Feel kinda stupid, voting to delete question. Thank you anyway! –  Znarkus Mar 12 '11 at 20:17
    
I would rather have added the solution as an answer, as this can be useful for others. Leave me a note if want me to vote for reopen. –  harrymc Mar 12 '11 at 20:31
    
Yeah sure, that makes sense. Please open again ;) –  Znarkus Mar 12 '11 at 20:57
up vote 0 down vote accepted

Tonight it magically just worked. Don't know what I did different. Maybe it was because I started the video when the movie window was on the projector screen, instead of moving it there afterwards. Maybe because I skipped right to the movie.

share|improve this answer

I fixed this problem !

Simply went into Media Player Classic → Options → playback → Direct Show video, Click the drop down menu and checked Advanced Video Renderer and it plays dvds.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.