Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on Windows Vista. I've been using IDLE, the default Python IDE ever since installing Python.

I long enjoyed the functionality of right-clicking a .py file and selecting "Open with IDLE" until one day, this was gone. The .py association seems to have been lost at that same time, as double-clicking a .py file will now open it in Notepad by default, and the thumbnail changed from the Python thumbnail to some unrecognizable default looking one.

Hitting F5 on an unsaved window of IDLE used to prompt me to save it, and then it would run it. Now, the prompt is skipped and it the "Open" dialog appears. Open!

I am positive that I've never touched IDLE's settings. What is going on?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

A few things can be going on and I am not entirely sure which.

If this is a shell extension (the same way as you get 7-zip or other actions on every file), then this is separate to the open file. I am not sure why it would be wiped, but your best bet would be to reinstall IDLE. There are numerous reasons it could of been removed.

If however, it is not a shell extension but just the default action, it is possible you installed another program/notepad tool and then uninstalled it. Its uninstall process could simply revert everything it supports to notepad without regard for your previous settings.

Simply right click and choose Open With then do Choose Default Program - The recommended ones at the top should be the previously used ones. Simply select the old one and it should open in that.

Please leave feedback if neither of these helped and I will try to come up with more solutions for you.

share|improve this answer
    
I'm using V3.1 which is no longer available, so I downloaded and installed V3.2 and that did not fix anything. I've tried Open With -> Choose Default Program before, and just like last time, I can't find the program (and yes, I did run a search for "idle.exe"). It did list a few recent options, all of which I tried, none of them worked. The Location field of the shortcut to IDLE is blank. :/ –  John Mar 12 '11 at 5:35
    
Launch IDLE, and launch process explorer, click and drag the target button at the top of it to IDLE, right click and do properties - it will show you the whole location of the application. –  William Hilsum Mar 12 '11 at 6:46
    
Found it! It was one of the old choices, but with an argument! Now, how do I replicate an argument in the Choose Default Program menu? Can I set it to open the default program with an argument? –  John Mar 13 '11 at 19:18
    
@John - read this answer I recently wrote - it should help you... superuser.com/questions/256759/… –  William Hilsum Mar 13 '11 at 19:33
    
That works perfectly! Thank you for all your help. –  John Mar 16 '11 at 3:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.