Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an HP Photosmart C5383 installed on a Windows XP Home PC. I got a notebook with Windows 7 Home Premium 64-bit, to upgrade my older Vista Home Premium 32-bit machine. I have shared this printer and been able to print successfully on the Vista machine, but when I try print on the Windows 7 machine, the spoolsv.exe service generates a C++ error and basically causes the Windows XP machine (the server) to hang until the service/process is stopped and restarted. The machines are obviously on a workgroup, good old MSHOME.

HP's support has no answers, and I cannot seem to find any solutions via a Google search.

All drivers are up to date and the Windows 7 machine detects the printer just fine, I even get a custom device stage when viewing the device on the notebook. But I can't print anything, and the spool service is crashing no matter what.

any thoughts?

share|improve this question

2 Answers 2

Problem solved.

http://helpdeskgeek.com/windows-7/xp-to-windows-7-printer-sharing/

I created a local port, instead of relying on the network version that was automatically created. That worked. I didn't know I could do that! :)

share|improve this answer

Actually for me just changing the name to a shorter one worked!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.