Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a HL-DT-ST RW/DVD GCC-4521B dvdrom device and a big problem.

Some days ago everything worked fine. A friend installed some software and then the drives in winxp has been marked as corrupt. I uninstalled the software, but still corrupt drives. The next step I have done was running the current software GCC-4521B101(E).exe. When I ran this software again, the drives was automatically updated, but still marked as corrupt (in the Device Manager), even if I did a reboot.

And then the big mistake: once more I tried to run this software, but during the update process, the machine restarted and boom! The DVDROM device doesn't work anymore. The led doesn't blink and if I push the eject button, nothing happens. Also bios and winxp doesn't recognize the optical drive.

Then I plugged an other optical drive and it worked, but my old drive seems to be dead.

So, what happened and how to solve this problem? Please help.

Regards!

share|improve this question

migrated from stackoverflow.com Mar 12 '11 at 13:13

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers

By the sounds of it you where updating the firmware on the CDROM device using GCC-4521B101(E).exe, try running that again, if it fails your device has been bricked.

share|improve this answer
    
I have tried to run it again, but the software doesn't recognize the device anymore. –  eman Mar 12 '11 at 13:11
add comment

I think it's broken and you have to dispose it ... If the Bios doesn't detect it it is very likely that the firmware can't adress it again

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.