Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently installed Unbuntu Desktop 10.10 on a partition alongside my normal Windows 7 x64 install. I expected to have only one OS boot menu which I would be able to edit via msconfig.exe in Windows. However I have two seperate sets of boot menus.

The first one contains a bunch of different Ubuntu boot options and also contains an option to boot to Windows 7 (this is last in the list).

If I choose windows 7 then I get presented with a second boot menu containing two options:

  • Windows 7
  • Ubuntu

The first boot menu defaults to Ubuntu and is on a short timeout. I want to change this to default to Windows 7 and increase the timeout. Can anyone help?

Google tells me to edit /boot/grub/menu.lst and although I do have a grub folder I don't seem to have a file called menu.lst: Change default operating system at boot

I'm an Ubuntu and Linux n00b so please be gentle with any answers.

share|improve this question

migrated from serverfault.com Mar 12 '11 at 19:40

This question came from our site for professional system and network administrators.

1 Answer 1

Ubuntu starting with 9.10 uses Grub 2. Grub 2 uses /boot/grub/grub.cfg instead of menu.lst, but you make changes in /etc/default/grub and use update-grub or update-grub2 to update it. Please see this for more information.

Change these settings:

GRUB_DEFAULT=0
GRUB_TIMEOUT=10

To something like:

GRUB_DEFAULT="Windows 7"
GRUB_TIMEOUT=20

Where you'd substitute the actual name of the Windows 7 menu entry.

You can remove Ubuntu from the second menu by starting a Window CMD shell (after you've booted Windows) and running:

bcdedit /delete Ubuntu
share|improve this answer
    
hmm... that didn't work. –  Steve Mar 12 '11 at 19:28
    
I tried changing the entry to –  Steve Mar 12 '11 at 19:28
    
GRUB_DEFAULT="Windows 7" and I also tried changing it to GRUB_DEFAULT="Windows 7 (loader) (on dev/sda1)" which is the exact text in the menu –  Steve Mar 12 '11 at 19:29
    
I also tried changing it to GRUB_DEFAULT=6 as it's the 7th entry in the list but this also had no effect, it just boots into Unbuntu after the timeout –  Steve Mar 12 '11 at 19:30
    
@SpookyAction: According the information that I linked to, you can use a text string to name a menu item. –  Dennis Williamson Mar 12 '11 at 21:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.