Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently using Ubuntu Maverick, and whenever I try to use a kernel newer than 2.6.32-21, I get this message:

ALERT!  /dev/mapper/localhost-root does not exist.  Dropping to a shell!

Does anyone have a clue what could be wrong? I'm not able to come up with anything.

The entry in /etc/fstab looks like this:

# / was on /dev/mapper/localhost-root during installation
UUID=dd17c070-dc6a-4b91-bb3c-458fd5f11342 / ext3 relatime,errors=remount-ro 0 1

The hardware details are here: http://cdgenp01.csd.toshiba.com/content/product/pdf_files/detailed_specs/satellite_L305D-S5928.pdf

share|improve this question

3 Answers 3

up vote 3 down vote accepted

My boot configuration was borked in several ways, I guess because I fiddle with things too much. Here are the problems and solutions. Essentially all of these commands need to be run as root, so run sudo -s beforehand.

1) The boot process didn't support LVM. You can check this by running gunzip < /boot/initrd.img-2.6.35-27-generic | cpio -id and checking for sbin/lvm.

To fix: (you only need one of these, but both doesn't hurt)

apt-get install lvm2
dpkg-reconfigure lvm2

2) My swap partition wasn't mounting. You can check this with the free command. The swap-total should be non-zero.

To fix:

swapoff  -a
mkswap -f -L SWAP /dev/mapper/mymachine-swap_1 
blkid
vim /etc/fstab (change the UUID's to match the output of blkid)
swapon -a
share|improve this answer

Are you compiling your own kernel? If so, you'll get this message if your root volume is on an LVM but necessary modules for LVM are not available either built-in to the kernel or on the initrd.

share|improve this answer
    
Nope I the standard Ubuntu kernels. Is there any other way my LVM could get messed up? –  bukzor Mar 13 '11 at 4:50

I also encountered the problem, fought it with no great success, but the solution in the end was to choose an older kernel in Grub under "Advanced options for Ubuntu".

System booted nicely and it was fixed with later upgrades.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.