Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have tried enabling the boot logging option for Windows XP Pro using the F8 and also boot.ini method, but it does not seem to be creating the expected ntbtlog.txt file. I'm doing this to help me solve a problem where the Avast antivirus service is not starting up - it keeps complaining with the message: "Error 1068: The dependency service or group failed to start".

I seem to notice that the file is produced on a system where the Avast antivirus is starting up without any problems. Can anybody suggest why the ntbtlog.txt file is not being created?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

The reason that ntbtlog.txt is not getting created on your system on which Avast is unable to run is likely due to the fact that it uses a driver which is not starting. Drivers are loaded early in the boot process and ntbtlog.txt isn’t written until the session manager runs, which occurs after the drivers are loaded. So if Avast’s driver is causing a problem, then the boot-log may not get written. I had a similar problem a while back and found an MS knowledge base article that gave a clue to the reason. Of course it doesn’t help solve the problem.

Use Autoruns to view the installed drivers (reduce the clutter by selecting verify and hide). You should see one or more Avast related drivers. If you disable them and reboot (selecting the boot-log option), you should get the file.

The next step is to figure out how to fix Avast—short of just reinstalling it. (Of course you’ll want to re-enable the its drivers.)

Run Services.msc and open the Avast service(s) and switch to the Dependencies tab and look at the top box. It should show you what services or drivers it depends on. That will help narrow down what’s causing the issue.

share|improve this answer
    
Thanks. That gave me some idea on where to start. The file seems to be created after I disabled all the Avast drivers at startup. –  Xolstice Mar 17 '11 at 1:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.