Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am on Ubuntu 10.4. My standard keyboard is QWERTZ, but I usually use the Dvorak layout.

When I type inside the GNOME terminal, the layout is the one I set in keyboard preferences (e.g. Dvorak). However, as soon as I use the Ctrl-[key], the keys are remapped to the QWERTZ layout. For example if I want to hit Ctrl,-c, I actually have to use Ctrl-j in Dvorak.

This only happens in the terminal, and only for applications that run inside the terminal. Shortcuts of the terminal (like Ctrl-Shift-c for copying) use the correct current keymap.

Any suggestions how this can be fixed?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I had exactly the same problem, and it drove me crazy. You have to change the order of the keyboard layouts:

  • Click on the keyboard icon (or System->Preferences->Keyboard)
  • Go to Layouts
  • Click on the Dvorak Layout and click Move Up until it's at the top

It seems that Gnome uses the top one for the keyboard shortcuts, but all of the other programs use the current layout. I don't think there's a way to have Gnome use the current layout for it's shortcuts.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.