Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm setting up a small home network. I have a laptop which connects to internet wirelessly- that works fine. I have a desktop connected to this laptop by an ethernet cable which I'd like to access the internet with. In the past, I have used a different laptop to do this and had no problems doing so.

Both computers run Windows 7. I have tried setting up a homegroup and disabling Windows firewall, as well as restarting both computers. I can share data but my internet connection can not be accessed through the desktop. I've looked at the Windows ICS resource but it was no help

(I understand USB network adapters are cheap, I have one on the way but that doesn't solve this issue.)

share|improve this question
    
Are you sharing your wireless connection through the ethernet connection with ICS? –  Majenko Mar 13 '11 at 17:00
    
Yes, I allowed for the wireless connection be be shared. I didn't select any "services" to be shared but I don't think any of them apply. –  Decency Mar 13 '11 at 17:34
add comment

3 Answers 3

up vote 3 down vote accepted

Windows Homegroup is about sharing files/printers and more in a user friendly manner - not internet.

Windows Internet Connection Sharing (ICS) is the route you want to go down.

If however you cannot do this, you can look at bridged networking.

As DHCP will not work, you need to set up an IP configuration in a separate range to the main network.

I would advise you use the following settings as they should not conflict with anything (If you use the 10.x range, let me know and I will change)

Laptop Ethernet settings:

IP : 10.0.0.1
Subnet : 255.255.255.0
Gateway : Blank

DNS : Blank

Every other machine:

IP : 10.0.0.2 (and add one)
Subnet : 255.255.255.0
Gateway : 10.0.0.1

DNS : 8.8.8.8 (or your favourite dns provider).

Next, on the laptop, select both the wired and wireless, right click and choose bridge.

I hope this helps!

share|improve this answer
    
Wil, thanks for the instructions but I've spent 10 minutes and I can't find out where I'm supposed to input these. I have no problem going into BIOS or the registry if needed, but I'm a novice with networking. –  Decency Mar 13 '11 at 17:35
    
Go to network connections and right click on "ethernet adapter" or whichever one is for your network card, then double click on IPv4, and put them there. –  William Hilsum Mar 13 '11 at 17:42
    
Okay, I've added those IP configurations to both machines and bridged the two connections. The desktop is not picking up/listing the connection, however. It still reads "Unidentified Network" and is not connected to the internet. –  Decency Mar 13 '11 at 17:54
    
can you try from the desktop ping 192.168.0.1 and ping 8.8.8.8 and let me know if both work or timeout? –  William Hilsum Mar 13 '11 at 18:01
    
192.168.0.1 and 8.8.8.8 both give the message: Destination host unreachable. The request timed out once for 192.168.0.1 as well (25% loss). Replies are coming from 10.0.0.2, if that's relevant. –  Decency Mar 13 '11 at 18:08
show 2 more comments

A Homegroup isn't a method for internet connection sharing. This should help:

http://windows.microsoft.com/en-US/windows-vista/Using-ICS-Internet-Connection-Sharing

share|improve this answer
add comment

If you connect the laptop and desktop via a crossover cable (not a straight cable) then you can simply "Share" the wireless connection and your desktop should have access. you can still leave the firewall active on your wireless connection.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.