Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The original questions was asked in 2009. Upgrade to a laptop using a 320 gb drive. When the new drive was formatted it was seen by the system as a 320 gb drive. (Small loss from OS so it was actually seen as about 305 gb.) When the old programs were copied over the system suddenly saw the drive as a 60 gb hard drive. Acronis was used to clone the drive. But once the old files were copied over the system will only see it as a 60gb drive.

I have tried removing the MBR, I have tried using a different system with a bio that I know will see 500 gb drives, and now the 320 is only seen as a 60 gb drive. So like the crazy optimist that i am a took a second 320 gb drive and repeated the steps. This time not copy only any files until I had formated the ne wdrive and added an OS to it. Initially shows as 305 gb formated. Copied old program files over and somehow repeated the process. Now it is a 60 gb drive. The drive is a WD 320. Any help would be appreciated. How do I get it to return to its 320 gb state?

share|improve this question
1  
What method do you use to copy the old program files over? Drag and drop in explorer, or some more exotic method? –  dsolimano Mar 13 '11 at 21:17
    
Duplicate of superuser.com/questions/28339 ? –  Dean Perry Mar 13 '11 at 21:18
    
Just a note on the difference between the number on the box (320 GB) and the number the OS reported (305 GB). It has to do with how GB is defined. The OS defines it as 1024 MB in a GB and 1024 B in a MB, but the HD manufacturer uses 1000 instead of 1024 in both cases. If you change the manufacturers units to bytes (320 * 1000 * 1000) and then convert the result to how the OS views it (320,000,000 / 1024 / 1024) you get 305 - it is not due to what the OS uses up, that is subtracted from the 305 in what it records as available space. –  MaQleod Mar 13 '11 at 21:52

2 Answers 2

Though I'm not able to test, there is some suggestion at this thread that the root cause of problems like this is related to the HPA, which is being restored to its old place, causing the drive to appear smaller. The relevant passage starts here:

I'm not a TI user, but I can tell you about the Dell MBR and HPA. This problem will occur when cloning any Dell computer with a HPA. The only Dells using a HPA are Inspiron laptops with factory-installed MediaDirect 2. (FTR, current Dell laptops are shipping with MD 3, which does not use a HPA.)

PatrickR has correctly identified the problem as the Dell MBR, and it will occur anytime you instruct TI to copy track-0 as part of the cloning operation. The Dell MBR (in Sector LBA-0) uses extended boot code in Sector LBA-3. Here is precisely how the MBR works. . . .

I'm not familiar with Acronis True Image, but it looks like maybe you are attempting to restore a disk image from the smaller drive, which causes problems. From the Arconis support forum, it looks like it should be possible to mount a .tib in a running installation of Windows and then copy the files off that you want.

Could this be what's going on?

share|improve this answer

For me the cure was to extend the filesystem to match the partition boundary after imaging to the new drive. At a command prompt:

C:\ > DISKPART
DISKPART> List Volume
DISKPART> select volume X      # (from volume listed by previous command)
DISKPART> extend filesystem
DISKPART> exit

Now Windows Explorer shows the new expanded size of the disk.

Solution courtesy of I Expanded the Disk in Disk Manager but It Doesn't Show in Windows Explorer

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.