Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm unable to access a Windows 7 (Windows 7 Pro 64-bit) shared folder from an old Windows 98 box: I tried with:

  • Turning on file and printer sharing
  • Turning on public folder sharing
  • Turning off password protected sharing
  • Sharing the folder with read permissions to Everyone
  • Lowering the encryption to 40-56 bits.

The shared folder works fine using it from Windows XP, and even from Linux with CIFS / Samba, but when I try to use it from Win98 with:

NET USE X: \\SERVER\SHARE

an user / password dialog pops up. I entered the administrator's user / password from my Windows 7 box, but it doesn't work (incorrect password). The same Win98 machine works fine accessing a Windows XP shared folder, so it looks like a Windows 7 networking issue.

Any ideas?

share|improve this question
    
Did you try with only the \\IP_Address\Shares$ ? –  r0ca Mar 14 '11 at 1:36
    
@r0ca: yes, I tried with \\ServerIP\Share, same result –  PabloG Mar 14 '11 at 1:43

3 Answers 3

Try supplying the user name as servername\username

It could be trying to authenticate using the 98 machines local admin account instead of the remote machines.

share|improve this answer
    
the Win98 popup only allows to enter a password, not a username, the username is always (to my knowledge) the Win98 logged user. –  PabloG Mar 14 '11 at 1:38
    
Yeah that'll be the bulk off the problem. It is trying to authenticate with an account Win7 has no record of. You could trying changing the permissions on the shared folder so that "Everyone" has full access. It should then not prompt for password... should. Other than that firgure out a way to specify a username on the 98 machine, or... upgrade to XP :P –  Windos Mar 14 '11 at 1:44
    
yeah, I tried with "everyone / full access", no luck. I cannot migrate the PC to XP because it has an old Psion SSD card with a 16-bit driver (really!) not supported on XP. –  PabloG Mar 14 '11 at 2:00

There are a few settings you need to change, particularly with Password Protected Sharing. It's all explained here on one of Microsoft's web sites:

  Cannot connect to Windows 7 shares (from Windows 98)
  http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/cannot-connect-to-windows-7-shares/002eee5d-9492-4b5f-9657-c076cc977d0d

share|improve this answer
    
@Randolf: the password protected sharing is off as posted initially. Thanks anyway –  PabloG Mar 14 '11 at 1:35
    
There are other settings mentioned in that document; Password Protected Sharing is only one of them. –  Randolf Richardson Mar 14 '11 at 2:08
    
@Randolf: all my network settings match your link: current profile (Work), Network discovery on, file and printer sharing on, public folder sharing on, media streaming off, password protected sharing off. –  PabloG Mar 14 '11 at 2:40
    
Assuming you're behind a hardware firewall already, try disabling the Windows Firewall features on your computers (I think only Windows 7 will have this if I recall correctly), then try again. –  Randolf Richardson Mar 14 '11 at 5:16
    
Another thing to try is accessing the Windows 7 computer by it's IP address. Assuming it's IP address is 10.1.1.7, try this: NET USE X: \\10.1.1.7\Share –  Randolf Richardson Mar 14 '11 at 5:17

I've had the same problem for a long time. I blamed Windows 7 x64, because I have a laptop running Windows 7 x32 Ultimate and no problems accesing shared network folders on that.

I have ESET Smart Security, maybe I didn't configure the network correctly when I first accessed the WiFi with the x64 computer — it was the firewall! Seemed so obvious once I had it working. I disabled the firewall on ESET and it worked, later I realized what was wrong …

I entered Advanced Setup, went to Firewall and changed the settings to trust my WiFi network, that was it!

Try it on your antivirus, or Windows Firewall. I've disabled Windows Firewall and only have ESET's firewall on. If you allowed sharing when you first added your WiFi, you're set, no problems there. The problem starts when adding the WiFi to the computer. If you selected "do not allow" sharing and when Windows pops up asking if it's a home/work/public network, you select public, your're screwed.

For trusted networks, select both on antivirus firewall and windows network: trusted/home, allow/home, or whatever term your antivirus uses.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.