Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows XP Professional, SP3. I'm running a webserver which listens on port 80. I have a dedicated ip address. Localhost on 80 resolves ok:

http://localhost:80

but I cannot get it to resolve externally:

http://external.ip.address:80

I can however get another port to resolve externally:

http://external.ip.address:1234

The Windows personal firewall is turned off. I've also stopped IIS. Is there something else that could prevent this from working?

share|improve this question
    
Your router, possibly. –  user3463 Mar 14 '11 at 4:07
    
Hmm no router, cable line goes direct to the machine. –  mark Mar 14 '11 at 4:46
    
You still have a router, whether it's called a "cable modem" or router, its job is to route traffic to your computer. –  user3463 Mar 14 '11 at 4:47
    
Please clarify - what web server software are you using? –  Majenko Mar 14 '11 at 10:21
    
@mark Please run this command and post the output. It will tell us if the web server is listening on the external IP or not: netstat -an | find ":80" | find "LISTENING" –  Majenko Mar 14 '11 at 11:11
show 1 more comment

1 Answer

up vote 1 down vote accepted

I presume you have restarted IIS/turned it back on.

This will be down to one of two things:

1) You have not set up your router correctly. Whilst some applications such as games can use UPnP or other technologies to "bypass" / create rules on the router, many server based applications are designed for corporate environments which do not allow this. You will need to forward the ports yourself. Take a look at Port Forward for information on how to do this if you are not sure.

2) Your ISP blocks it. This is unlikely if you have been issued a static IP, however it is possible - a lot of ISPs block port 25 and 80. If this is the case, you can ask them to unblock it, however no guarantees that they will. It depends on their policy.

share|improve this answer
    
No router. It's probably the isp. Resolves just fine from the outside if I use a port other than 80. Resolves internally if port 80. I'm sure iis is not running. –  mark Mar 14 '11 at 4:46
    
@mark - IIS (or whatever webserver you are using) NEEDS to be running! - IIS is what responds to port 80, you would not be able to access the website from other machines on your network if port 80 was off. –  William Hilsum Mar 14 '11 at 5:18
    
... However, you may also want to check the bindings of the website in IIS are set to all and not just your internal IP. –  William Hilsum Mar 14 '11 at 5:19
    
Check with your ISP - some ISPs may permit you to enable port 80 access but have it disabled by default (mine, for business, does this). –  Multiverse IT Mar 14 '11 at 6:55
    
Mark is not using IIS but a third party webserver - hence IIS is turned off and I can get to port 80 internally. –  Majenko Mar 14 '11 at 9:20
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.