Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In the last week, some of my USB devices have failed to be recognised on my Windows XP SP3 laptop.

It first happened with 2 external USB HDD enclosures connected through a mini USB hub. Connecting them individually did not resolve the problem. The error I received was:

USB device not recognized. One of the USB devices attached to this computer has functioned, and Windows does not recognise it.

More importantly, the laptop is no longer recognising my USB thumb drive, which functions perfectly on my Windows 7 machine at work.

Can I reinstall my USB drivers? Do I just delete the USB devices, reboot, and let Windows reinstall them? Do they need to be manufacturer-specific drivers?

share|improve this question
    
I've removed and reinstalled my USB hubs etc. from Device Manager, but one device is not installed properly: Mass Storage Controller. This is obviously preventing me from accessing the USB thumb drive and external HDDs. Where do I obtain the drivers for this if WinXP does not have them? –  Steve Mar 14 '11 at 13:30
    
How are the USB sticks formatted? NTFS? FAT32? exFAT? –  paradd0x Mar 14 '11 at 14:55
    
Pretty sure they are FAT32 (the defauly format). –  Steve Mar 15 '11 at 1:42
    
I went into the properties of the Mass Storage Controller in Device Manager and copied the device ID. I did a Google search and was surprised to find it was a card reader. I downloaded the drivers from my manufacturer's website, and Windows detected and installed the drivers for the card reader, as well as the Mass Storage Controller. The USB thumb drive appeared in Explorer, but displayed 0 items. I will try a reboot. –  Steve Mar 15 '11 at 12:40
    
After the reboot the thumb drive is not displayed in Windows Explorer, and when I unplug and reinsert it an error appears saying the USB device is not recognised and has malfunctioned. –  Steve Mar 15 '11 at 14:24

3 Answers 3

up vote 2 down vote accepted
+50

I remember encountering this issue once on my notebook - external drives, usb mouse, nothing worked, regardless of which port I used. In the end, I plugged it off, took out the battery and left it out cold overnight. Everything worked fine next day.

I still don't have any idea what happened.

share|improve this answer

It might be enough to just unplug the notebook from the electric outlet (after turning it off and unplugging ALL devices), and letting it sit there for some time before turning it on again.

If this doesn't work, follow the solution of Woozy Luke.

share|improve this answer
    
The answer from Woozy Luke is not visible to me. It worked. –  Steve Mar 22 '11 at 10:48

There is not enough info to really give a good answer.

  1. You disk are failing, so the usb component works fine but the file system is corrupt. I have seen this problem cause by not ejecting the drives properly which made them apeare to be in accessible.

    • You need to format the disk,
    • or recover the file system on the disk. ntfstools on linux would make this quite easy. or testdisk
    • or recover the file system journal on an ntfs disk. Leave the disk plugged in and restart the computer twice.
  2. mini USB hub

    • The USB hub needs extra power or is creating conflicts on the USB interface. Avoid using it, get a powerd USB hub. Here you get what you pay for, some cheap usb hubs don't work properly.
  3. Deleting the device in device manger.

    • Windows XP should handle the drivers transparently. Deleting them window device manger would not cause any harm. Windows should reinstall the device correctly.
    • If it does not work try looking at potential virus that can cause this problem. Run some virus checks on the XP machine and do a virus check on the thumb drive under windows.
    • Thumb drives have a shelf life. Is it past it expiry date.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.