Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This laptop hasn't been used in almost a year. It connected to the internet just fine last time used. Now it can't get on line. ipconfig:The Gateway setting for this computer is empty. Make sure your access point is working properly.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.
C:\Documents and Settings\Dodi>IPCONFIG /ALL
Windows IP Configuration

        Host Name . . . . . . . . . . . . : 8A287A4ADEF0487
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : Yes
        WINS Proxy Enabled. . . . . . . . : No
Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : LAN-Express AS IEEE 802.11g miniPCI
Adapter
        Physical Address. . . . . . . . . : 00-14-A4-72-37-E1
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.0.1
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :
        DNS Servers . . . . . . . . . . . : 192.168.1.1
Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
        Physical Address. . . . . . . . . : 00-01-4A-EF-A8-7D

How do I fix this?

share|improve this question
    
You’ve got two network adapters; which one did you use before, when it was working? Also, you’re connecting to your router, so you’ll need to make sure that it is correctly configured for that adapter. –  Synetech Mar 14 '11 at 19:21
    
@Synetech It was connected to a Linksys through Ethernet. I now have a Netgear WNDR3300 RangeMax Dual Band Wireless-N Router hard wireded to my desktop and have two other laptops that are all working fine. How do I make sure it is correctly configured I can't bring up my router page? –  Dodi Jones Mar 14 '11 at 21:24
    
Can you configure your router with one of the other systems? If you now have three systems connected to the router, you’ll probably need to configure the router’s DHCP settings. You could also try manually setting the information for your network adapter to see if it can connect. If so, then it is indeed the DHCP settings of the router that need to be set. –  Synetech Mar 14 '11 at 21:42
1  
Just turn DHCP on on the laptop. It should get its settings from the Netgear (unless you have disabled DHCP on there - I believe it is enabled by default - my DGN2200 was). –  Majenko Mar 14 '11 at 23:01
    
@matt it is enabled in services but when I bring up ipconfig it says its now enabled. I don't know of any other way to trun it on other then in Services –  Dodi Jones Mar 15 '11 at 4:14

1 Answer 1

Enabling the DHCP service in Services.msc only enables the service, you still need to enable it for (each) network adapter.

  1. Open the Control Panel
  2. Open the properties of your network adapter(s)
  3. Open the properties for TCP/IP
  4. Make sure that Automatic is selected for the settings

enter image description here

share|improve this answer
    
Thank you for all the help but nothing worked so I restored it back to factory spec's and it's working just fine. –  Dodi Jones Mar 16 '11 at 2:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.