Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get ubuntu working w/ 3 monitors. I have been given 2 video cards

lspci | grep VGA

20:01:00.0 VGA compatible controller: ATI Technologies Inc RV620 LE [Radeon HD 3450]
25:05:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1)

I have had it working w/ two monitors plugged into the ATI correctly. and the nVidia monitor blank. Now I have the nVidia monitor working and one monitor from the ATI working, but I can't seem to get the last monitor to show anything. It does show the boot screen and works up until the point you are presented w/ the login screen for ubuntu, then it disappears and the nVidia monitor turns on. Might I have something wrong w/ my xorg.conf or do I need to do something more to get this to work?

Currently I'm seeing this error in my Xorg.0.log file, but I'm not sure where to go from here:

[    24.746] (EE) RADEON(2):  reusing fd for second head

/etc/X11/xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 270.29  (buildmeister@swio-display-x86-rhel47-02.nvid

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      "Screen1" RightOf "Screen0"
    Screen      "Screen2" RightOf "Screen1"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
    Load    "dbe"       # Double-buffering
    Load    "GLcore"    # OpenGL support
    # Load  "dri"       # Direct rednering infrastructure
    Load    "glx"       # OpenGL X protocol interface
    Load    "extmod"    # Misc. required extensions
    # Load  "v4l"       # Video4Linux
    Load    "record"    # X event recorder
    Load    "freetype"  # TrueType font handler
    Load    "type1"     # Adobe Type 1 font handler
EndSection

Section "ServerFlags"
    Option "Xinerama" "true"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Dell0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Dell1"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSectiSection "Monitor"
    Identifier     "Dell2"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier  "RD3450"
    Driver      "radeon"
    BusId       "PCI:01:00:0"
    Screen      0
EndSection

Section "Device"
    Identifier  "RD34501"
    Driver      "radeon"
    BusId       "PCI:01:00:0"
    Screen      1
EndSection

Section "Device"
    Identifier     "GF6200"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusId          "PCI:05:00:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "GF6200"
    Monitor        "Dell0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "RD3450"
    Monitor        "Dell1"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen2"
    Device         "RD34501"
    Monitor        "Dell2"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "DRI"
    Mode    0666
EndSection
share|improve this question

migrated from stackoverflow.com Mar 15 '11 at 0:28

This question came from our site for professional and enthusiast programmers.

    
Try askubuntu.com –  Paul Dixon Mar 14 '11 at 23:44
add comment

2 Answers

First off in your ServerLayout section you have it shown as:

Screen      0  "Screen0" 0 0
Screen      "Screen1" RightOf "Screen0"
Screen      "Screen2" RightOf "Screen1"

You are missing the screen labels. You need it to look like the following.

Screen      0  "Screen0" 0 0
Screen      1  "Screen1" RightOf "Screen0"
Screen      2  "Screen2" RightOf "Screen1"

Everything else in your post looks correct in the xorg.conf. The only other issue I see is that you are running an nvidia and ati video chipset. The reason being, I know that the drivers from Nvidia's site will remove some of the necessary drivers for ATI. Unless you want to use the open nvidia drivers or vesa to manage that third monitor.

Please post your Xorg.0.log and I will be able to point you in the right direction.

share|improve this answer
add comment

I noticed that you combined the end of one "Monitor" section (for "Dell1") with the beginning of another "Monitor" section (for "Dell2") so the line looks like:

Section "Monitor"
    Identifier     "Dell1"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Dell2"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.