Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the Soft Tabs option in TextMate, but my files still contain TAB characters instead of "4-spaces". This is how it works:

  1. I open a file, it contains TABs
  2. I turn on the Soft Tabs option
  3. I save the file.

Nothing is changed, the file is still full of TABs. What am I doing wrong?

share|improve this question
    
Which part of the documentation claims that it will replace existing tab characters? –  Ignacio Vazquez-Abrams Mar 15 '11 at 6:30
    
@Ignacio hm... This is what I'm reading: manual.macromates.com/en/working_with_text section 4.11. I had a feeling that it has to replace existing TABs. What is the workaround? –  yegor256 Mar 15 '11 at 6:34
add comment

1 Answer

up vote 17 down vote accepted

TextMate does not change your entire document based on such a preference. It is across document boundaries, so just the act of opening a file would change nearly every single line in it. Your colleague who always read the VCS change logs would want to kill you.

The file is not updated automatically. In TextMate 1, you need to invoke Text » Convert » Tabs to Spaces. In TextMate 2, you invoke Bundles » Source » Convert Tabs to Spaces. Both respect your current tab width setting.


Regarding the linked documentation:

When soft tabs are enabled, TextMate will for the most part act exactly as if you were using hard tabs but the document does indeed contain spaces.

This refers to navigation across multiple spaces. Even if you use spaces, moving the cursor will feel like they were tabs (i.e. jumping $tab_width spaces).

share|improve this answer
    
ctrl-appl-shift-t and then 2 –  AJcodez Nov 17 '13 at 21:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.